Bug 57114 - Need public replacement for internal ecos.db targets
Need public replacement for internal ecos.db targets
Status: CLOSED WONTFIX
Product: eCos
Classification: Retired
Component: CDL (Show other bugs)
CVS
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bart Veer
Bart Veer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-04 20:40 EST by Jonathan Larmour
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 12:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Larmour 2001-12-04 20:40:48 EST
Description of Problem:

As per the "edb7212/configtool bug in 1.5.7" thread on the internal
ecc-config list on 2001-12-05, libcdl and the build tools need to allow
some public replacement for the internal ecos.db targets that use
enable/disable/set_value.

Here's Bart's intended solution:
    >> Now, any enable/disable/set_value entries in the ecos.db file for
that
    >> target would be turned into "requires" constraints associated with
    >> this configuration option. So if the user selects a target
    >> edb7212 then there would now a constraint in the system
    >> 'requires { CYGHWR_HAL_ARM_EDB7XXX_VARIANT == "EP7212"}'.
    >> It would now be up to the inference engine to modify
    >> CYGHWR_HAL_ARM_EDB7XXX_VARIANT accordingly, and users cannot mess
    >> things up without getting reports of conflicts. Also, other CDL
could
    >> start using CYGHWR_TARGET for e.g. determining default values.
Comment 1 Alex Schuilenburg 2003-06-20 12:06:46 EDT
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id=57114

Note You need to log in before you can comment on or make changes to this bug.