Bug 571171 - Change the block IO host implementation to aio
Change the block IO host implementation to aio
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
All Linux
low Severity medium
: beta
: 7.0
Assigned To: Kevin Wolf
:
Depends On: 589985 615309 689830
Blocks: 580954
  Show dependency treegraph
 
Reported: 2010-03-07 06:41 EST by Dor Laor
Modified: 2013-03-15 08:05 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 08:05:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dor Laor 2010-03-07 06:41:56 EST
Currently we do not using configure with --enable-linux-aio and we should switch to that since Shak has performance results that state it is better than aio=threads.
Comment 1 RHEL Product and Program Management 2010-03-07 07:13:45 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 chellwig@redhat.com 2010-03-07 07:45:35 EST
Note that Linux aio support gets automatically built if we find libaio and it's headers.  So what needs to be done here it pull libaio-devel in as a build requirement.

Also note that we'll need a clone of this bug for libvirt to enable aio=native on the qemu command line,
Comment 3 Dor Laor 2010-03-07 08:26:33 EST
(In reply to comment #2)
> Note that Linux aio support gets automatically built if we find libaio and it's
> headers.  So what needs to be done here it pull libaio-devel in as a build
> requirement.

That's a rpm dependency change

> 
> Also note that we'll need a clone of this bug for libvirt to enable aio=native
> on the qemu command line,    

Isn't the above sufficient? Alternatively we can change the default ourselves in qemu.
Comment 4 chellwig@redhat.com 2010-05-07 07:06:39 EDT
Given that this recently came up on irc, what's the status?  Do we still want to change the default aio backend, and if yes do that in libvirt or by patching qemu?
Comment 5 Dor Laor 2010-05-09 10:40:16 EDT
(In reply to comment #4)
> Given that this recently came up on irc, what's the status?  Do we still want
> to change the default aio backend, and if yes do that in libvirt or by patching
> qemu?    

I think we rather change the default in qemu, there are far too many folks try qemu directly. It's the same like cache=off in the past.
Comment 6 chellwig@redhat.com 2010-05-09 13:10:10 EDT
If we're doing this as a RHEL only patch it's easy given that both raw block device (disk/lvm) and nfs support proper AIO.  If we want to do this upstream we also need to special case regular files on various local filesystems, especially if they are thinly provisioned.

Dor, is this okay as a RHEL-only patch?
Comment 7 Dor Laor 2010-05-10 05:01:41 EDT
If you can change upstream default for our use cases it will be even better. If not, rhel-only will do too. Adding Anthony to the BZ
Comment 16 chellwig@redhat.com 2011-06-07 07:29:04 EDT
Reassigning to RHEL7, as we're unlikely to get the upstream fix in in time.
Comment 18 Paolo Bonzini 2013-03-15 08:05:24 EDT
A non-issue for RHEL, since we always go through libvirt.  If the default has to change, the change has to be in libvirt.

Note You need to log in before you can comment on or make changes to this bug.