Bug 571192 - $ENV{"HTTP_TRANSFER_ENCODING"} may be undefined in SOAP::Transport::HTTP
Summary: $ENV{"HTTP_TRANSFER_ENCODING"} may be undefined in SOAP::Transport::HTTP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-SOAP-Lite
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-07 14:28 UTC by Joel Uckelman
Modified: 2011-05-17 00:56 UTC (History)
6 users (show)

Fixed In Version: perl-SOAP-Lite-0.712-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-10 03:26:35 UTC


Attachments (Terms of Use)

Description Joel Uckelman 2010-03-07 14:28:50 UTC
Description of problem:

I get the following error message when calling Bugzilla's xmlrpc.cgi, which uses SOAP::Transport::HTTP:

[Sun Mar 07 07:17:07 2010] [error] [client 146.50.208.39] [Sun Mar  7 07:17:07 2010] xmlrpc.cgi: Use of uninitialized value $ENV{"HTTP_TRANSFER_ENCODING"} in pattern match (m//) at /usr/lib/perl5/vendor_perl/5.10.0/SOAP/Transport/HTTP.pm line 530.

The offending line looks like this:

  my $chunked = ( $ENV{'HTTP_TRANSFER_ENCODING'} =~ /^chunked.*$/ ) || 0;

Since the Transfer-Encoding header will often not be present, wouldn't it be better to first check whether the key we're asking for exists?

  my $chunked = (exists $ENV{'HTTP_TRANSFER_ENCODING'} &&
                 $ENV{'HTTP_TRANSFER_ENCODING'} =~ /^chunked.*$/ ) || 0;


Version-Release number of selected component (if applicable):

perl-SOAP-Lite-0.710.10-1.fc12.noarch


How reproducible:

Always.


Steps to Reproduce:
1. Load the URL for Bugzilla's xmlrpc.cgi.
  
Actual results:

Call fails with the above error.


Expected results:

No error.

Comment 1 Joel Uckelman 2010-07-09 12:39:56 UTC
This still happens with perl-SOAP-Lite-0.710.10-1.fc13.noarch in Fedora 13.

Comment 2 rvalue 2010-10-12 00:34:03 UTC
Had the same problem with Fedora 13 distribution of Bugzilla & perl-SOAP-Lite packages.

Worked around by undoing my own configuration of Bugzilla to use mod_perl; the default (mod_cgi?) Apache configuration does not exhibit this error for me.

Are you using Bugzilla with mod_perl?

Comment 3 Paul Howarth 2010-10-12 06:44:44 UTC
This is reported upstream at https://rt.cpan.org/Public/Bug/Display.html?id=55618 and is supposedly fixed (along with various other issues) in SOAP::Lite 0.712.

Comment 4 Joel Uckelman 2010-10-12 08:56:26 UTC
rvalue: no, I'm not using mod_perl.

Paul: It's good to hear that it's been fixed.

Comment 5 Iain Arnell 2011-05-04 06:38:41 UTC
Re-assigning to Petr has he's the new package owner and has recently built 0.712 in rawhide, but may not have noticed this old bug.

Comment 6 Petr Šabata 2011-05-04 07:01:42 UTC
(In reply to comment #5)
> Re-assigning to Petr has he's the new package owner and has recently built
> 0.712 in rawhide, but may not have noticed this old bug.

No, I haven't.
Thanks, Iain.

I'll check if 0.712+ really fixes it and update current Fedoras if appropriate.

Comment 7 rvalue 2011-05-04 07:24:41 UTC
I think our BZ machine is still much the same setup if you want me to confirm a fix.

Comment 8 Fedora Admin XMLRPC Client 2011-05-04 12:05:42 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 9 Petr Šabata 2011-05-04 12:30:22 UTC
(In reply to comment #7)
> I think our BZ machine is still much the same setup if you want me to confirm a
> fix.

http://koji.fedoraproject.org/koji/taskinfo?taskID=3049652

Yes, please :)
I merged f1[345] with Rawhide, v0.712. Let me know if it works for you. I'll submit an update if it does...

Comment 10 rvalue 2011-05-04 14:10:58 UTC
(In reply to comment #9)
> (In reply to comment #7)
> > I think our BZ machine is still much the same setup if you want me to confirm a
> > fix.
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3049652
> 
> Yes, please :)
> I merged f1[345] with Rawhide, v0.712. Let me know if it works for you. I'll
> submit an update if it does...

* Error reproduced w/ existing install setup

* Attempt to install package from link w/
# rpm -Uvh perl-SOAP-Lite-0.712-3.fc13.noarch.rpm 
error: Failed dependencies:
	perl(Class::Inspector) is needed by perl-SOAP-Lite-0.712-3.fc13.noarch

(so, it seems this dependency is introduced with this package?)

* Attempt to install said dependency:
# yum install perl-Class-Inspector
(runs to completion)

* Re-do install
# rpm -Uvh perl-SOAP-Lite-0.712-3.fc13.noarch.rpm 
Preparing...                ########################################### [100%]
   1:perl-SOAP-Lite         ########################################### [100%]

* Re-started apache
# service httpd restart

* The error is no longer being logged, and so I presume this issue is fixed (but I'm still getting a HTTP 411 response trying to access bugzilla/xmlrpc.cgi) - I'll have a look at that in the morning, I guess.

Comment 11 Petr Šabata 2011-05-04 14:32:22 UTC
Yes, I changed the dependencies a bit.
Thanks for the test. I hope the new error isn't related :)

Comment 12 Fedora Update System 2011-05-04 14:33:45 UTC
perl-SOAP-Lite-0.712-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/perl-SOAP-Lite-0.712-3.fc13

Comment 13 Fedora Update System 2011-05-04 14:34:09 UTC
perl-SOAP-Lite-0.712-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/perl-SOAP-Lite-0.712-3.fc15

Comment 14 Petr Šabata 2011-05-04 14:43:51 UTC
Not creating an update for F14 since the package is 'deprecated' there.
There's a code in f14 branch, no reasons stated anywhere.

Would anybody know why?

Comment 15 Fedora Update System 2011-05-05 04:42:56 UTC
Package perl-SOAP-Lite-0.712-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-SOAP-Lite-0.712-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/perl-SOAP-Lite-0.712-3.fc15
then log in and leave karma (feedback).

Comment 16 Marcela Mašláňová 2011-05-05 07:32:59 UTC
https://fedorahosted.org/rel-eng/ticket/4693

Comment 17 Fedora Update System 2011-05-06 14:13:54 UTC
perl-SOAP-Lite-0.712-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/perl-SOAP-Lite-0.712-3.fc14

Comment 18 Petr Šabata 2011-05-06 14:15:01 UTC
(In reply to comment #16)
> https://fedorahosted.org/rel-eng/ticket/4693

Well, although the package is still orphaned/deprecated, I can release updates for F14. So be it.

Comment 19 Fedora Update System 2011-05-10 03:26:29 UTC
perl-SOAP-Lite-0.712-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2011-05-13 22:55:42 UTC
perl-SOAP-Lite-0.712-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2011-05-17 00:56:26 UTC
perl-SOAP-Lite-0.712-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.