Bug 57124 - controlling tty randomly disappears after upgrading to util-linux-2.11f-11.7.1.i386.rpm
controlling tty randomly disappears after upgrading to util-linux-2.11f-11.7....
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-05 07:38 EST by Andreas Beck
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-05 07:38:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Beck 2001-12-05 07:38:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.4.9-12custom i686)

Description of problem:
Since upgrading my RH 7.1 system to util-linux-2.11f-11.7.1.i386.rpm, I
often (not always) loose the controlling tty when logging in on a console.
This annoys programs like su,ssh and xggi that need a controlling tty for
various reasons. You have the problem, if you get
[becka@cupido becka]$ cat </dev/tty
bash: /dev/tty: No such device or address
right after logging in. The problem dis-/reappears in a random fashion with
each new login. Going back to /bin/login from
util-linux-2.10s-13.7.i386.rpm (only the login binary was fetched form
there) fixes it. Seemingly the fix for Bug 51646 has an unwanted side
effect. Note, that I am using fbdev with the matrox driver. Kernel version
has no influence (tried with 2.4.2 and 2.4.9 from source RPM).

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Log in on a VT on a machine running the abovementioned configuration.
2. enter cat </dev/tty

Actual Results:  bash: /dev/tty: No such device or address

Expected Results:  The cat should have echoed typed characters. Break with
Ctrl-C.

Additional info:
Comment 1 Elliot Lee 2001-12-05 10:54:19 EST

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.