Bug 57127 - Unnecessary dependencies for package
Unnecessary dependencies for package
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: python2 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-05 09:37 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-05 09:37:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-05 09:37:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
rpm --rebuild python2-2.1.1-2.src.rpm 
Installing python2-2.1.1-2.src.rpm
error: failed build dependencies:
        Mesa-devel   is needed by python2-2.1.1-2
        tk   is needed by python2-2.1.1-2
        tix   is needed by python2-2.1.1-2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1."server" install of RedHat 7.2
2.deselect X windows during install (install with no optional components)
3. rpm -Uvh /mnt/cdrom/RedHat/RPMS/python2-2.1.1-2.i386.rpm
	

Actual Results:  error: failed dependencies:
        libGL.so.1   is needed by python2-2.1.1-2
        libGLU.so.1   is needed by python2-2.1.1-2
        libtix.so.0   is needed by python2-2.1.1-2
        libtk.so.0   is needed by python2-2.1.1-2

Expected Results:  Install cleanly as the rpm from python.org did on 
RedHat 7.1!!!

Additional info:

python.org rpms for RedHat 7.1 are broken down into core and optional 
components, see below. PostgreSQL is an even better example of seperating 
the core from the components :-)
This is much more sane than throwing it all in the one rpm, especially for 
people who don't install X on servers. What do I need Mesa for on an app 
server??? 

python2-2.1.1-3.i386.rpm (RedHat-based 7.1 base RPM) 
python2-tkinter-2.1.1-3.i386.rpm (RedHat-based 7.1 tkinter RPM) 
python2-devel-2.1.1-3.i386.rpm (RedHat-based 7.1 development RPM) 
python2-tools-2.1.1-3.i386.rpm (RedHat-based 7.1 Tools RPM, including 
IDLE)
Comment 1 Trond Eivind Glomsrxd 2001-12-05 11:01:10 EST
The standard python rpms are split up - python2 is just included as a taste of
what will come later.
Comment 2 Need Real Name 2001-12-05 12:15:17 EST
When is later?  Zope 2.4.x has required python 2.1 since 2001/05/31
They're already working the Zope 2.5 track.
Python 2.2 is at beta2 already.
Python 1.5.2 is OLD. It was released 1999/04/13!!!
Does Anaconda not work on python 2.x or something? What's stopping the move 
away from python 1.5.2?
Comment 3 Trond Eivind Glomsrxd 2001-12-05 12:19:38 EST
The existing modules need to keep working inside a series. Besides, important
components likge glade,gtk etc. aren't that stable on python 2 yet.

We'll upgrade when we do a new series.

Note You need to log in before you can comment on or make changes to this bug.