Bug 57130 - rc.sysinit, delete X locks, rm -f /tmp/.X11-unix/* for vncserver
Summary: rc.sysinit, delete X locks, rm -f /tmp/.X11-unix/* for vncserver
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-05 16:05 UTC by Alain Spineux
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 19:22:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alain Spineux 2001-12-05 16:05:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917

Description of problem:
The vncserver service don't restart after a crash because the lock in
/tmp/.X11-unix/X* is still there.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.make vncserver start at boot time (chkconfig ...)
2.add an entry in /etc/sysconfig/vncserver
3.restart the conputer
4.verify vncserver is working using vncviewer
5.crash (turnoff) your computer
6.reboot
7.vncserver is not working anymore because the lock is still there
	

Actual Results:  vncserver is not working anymore because the lock is still
there

Expected Results:  vncserver was working

Additional info:

EASY to fix, just add 
  # Delete X locks
  rm -f /tmp/.X*-lock
+  rm -f /tmp/.X11-unix/*
in /etc/rc.d/rc.sysinit
maybe vncserver can be more agressiv against bad lock files.
probably occur in 7.2 too.

Comment 1 Bill Nottingham 2005-09-29 19:22:06 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.