This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57134 - Resizing window generates stdin junk on Terminal
Resizing window generates stdin junk on Terminal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-05 11:55 EST by Michael Heins
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 15:51:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Heins 2001-12-05 11:55:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
When I resize a window, the process listening to the
window's stdin gets garbage characters, causing random havoc.

I'm running Gnome/sawfish.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Bring up a Terminal window.
2. rsh/rlogin to a remote Linux system to get a shell.
3.Grab a corner of the window with the mouse and drag it
  around for a few seconds.  Repeat until bug shows up.


Actual Results:  Random junk (probably random binary characters) may appear
on the stdin of the remote shell.

Expected Results:  Resizing the window should never generate stdin input.

Additional info:

I don't know if the 'rsh' is necessary, but so far I have
only seen the problem under those conditions.
Comment 1 Havoc Pennington 2001-12-05 12:54:42 EST
I can't get this to happen; what are the rsh and bash versions on both 
local and remote machine, maybe?
Comment 2 Michael Heins 2002-02-27 12:07:02 EST
Local bash version:
GNU bash, version 2.05.8(1)-release (i386-redhat-linux-gnu)

I don't know how to get the rsh version, but I haven't altered it since
upgrading to RH7.2 and installing some updates from RedHat:

[mth@zap mth]$ which rsh
/usr/kerberos/bin/rsh
[mth@zap mth]$ ls -l /usr/kerberos/bin/rsh
-rwxr-xr-x    1 root     root        23756 Aug  3  2001 /usr/kerberos/bin/rsh

Problem is independent of remote system shell and rsh because it happens on
a variety of different platforms/OS'es

ADDITIONAL INFORMATION:  Problem is related to how windows are animated when
resized.  I had been using "opaque".  When I changed to "box", problem went
away.  I suspect that the "opaque" case is generating events that are somehow
not being handled properly, but instead are interpreted as kbd input.
Comment 3 Kjartan Maraas 2004-03-29 15:51:24 EST
Closing this as fixed since the GNOME version is ancient and the
terminal was rewritten in the meantime. Please file upstream if it's
still a problem.

Note You need to log in before you can comment on or make changes to this bug.