Bug 57143 - aic-7xxx module does not allow cdrom to be mounted
aic-7xxx module does not allow cdrom to be mounted
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-05 14:19 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 19:20:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-05 14:19:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
I have an HP Netserver (5/100LC) with the Adaptec AIC-7770P SCSI embeded 
controller. When the system boots, it recognizes all scsi devices (sda, 
sdb, sdc, and scd0), but will not allow the cdrom to be mounted 
("unrecognized device" error). The problem occurs both with a Sony CDU-76S 
and Toshiba XM-4101B. In RH7.1, I was able to use the aic-7xxx driver with 
no trouble at all. I have tried the aic-7xxx_mod driver and was able to 
mount the cdrom just fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH7.2
2.Select the correct driver for the Adaptec AIC-7770P scsi controller
3.Boot the system and type "mount /mnt/cdrom"
	

Actual Results:  unrecognized device

Expected Results:  CDROM mounted on /dev/cdrom

Additional info:
Comment 1 Need Real Name 2001-12-10 15:30:29 EST
I recently discovered that wether I choose the aic-7xxx or the aic-7xxx_mod 
scsi driver, neither will allow the mounting of the CD-ROM after the initial 
install. The aic-7xxx_mod driver does get through the installation without 
errors, while sometimes the aic-7xxx driver cannot find the CD-ROM that I use 
for boot/install.

After booting initially, I edit the /etc/modules.conf to the driver (aic-7xxx 
or aic-7xxx_mod)other then the one selected initially and restart, I am able to 
mount the CD-ROM just fine.
Comment 2 Arjan van de Ven 2001-12-13 04:06:11 EST
Hmmmm
Have you tried running "depmod -ae" as root?
That appears to fix a very similar issue for several people
Comment 3 Alan Cox 2003-06-07 19:20:39 EDT
No reply in a year, closing

Note You need to log in before you can comment on or make changes to this bug.