Bug 571441 - Please do not push incompatible changes into EPEL
Summary: Please do not push incompatible changes into EPEL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-08 14:47 UTC by Lubomir Rintel
Modified: 2013-01-10 05:45 UTC (History)
3 users (show)

Fixed In Version: mock-1.0.7-1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-26 23:26:44 UTC
Type: ---


Attachments (Terms of Use)

Description Lubomir Rintel 2010-03-08 14:47:09 UTC
Description of problem:

Mock 1.0.5 changed default of useradd to use -N flag, which is not in RHEL's useradd. This effectively broke all custom el5 configurations for earlier versions.

Please do not do that, EPEL users don't expect this sort of Regressions.

Version-Release number of selected component (if applicable):

1.0.2 vs. 1.0.5

Additional info:

I'm wondering why do I open this bug; not sure if for example changing the site-defaults for backward compatibility make sense. If not, please just acknowledge that you're okay with EPEL policies and close this...

Thanks!

Comment 1 Lubomir Rintel 2010-03-08 14:57:32 UTC
(In reply to comment #0)
> If not, please just
> acknowledge that you're okay with EPEL policies and close this...

Well, I'm not really sure if there's a policy for this. Probably s/policies/customs/ ...

Comment 2 Jesse Keating 2010-03-08 22:20:39 UTC
In hindsight this probably wasn't the best idea to push, however I was not expecting many people to have many custom configs, and would have noticed the .rpmnew file to look into.

We have a problem though.  The default will either be acceptable for EPEL or acceptable for Fedora, but it can't work for both, so one set has to be overridden in config files.  What can we do here?

Comment 3 Lubomir Rintel 2010-03-09 09:12:37 UTC
Is there anything wrong with pushing a package with different default into EPEL than into Fedora?

Comment 4 Lubomir Rintel 2010-03-09 10:48:35 UTC
By the way createrepo_on_rpms could also be False by default, since it breaks setups where two concurrently running mocks share the same resultdir (not questioning the sanity of such setup, it's still a regression in behavior).

Comment 5 Jesse Keating 2010-03-09 15:55:02 UTC
(In reply to comment #3)
> Is there anything wrong with pushing a package with different default into EPEL
> than into Fedora?    

That doesn't work, because if you used your EL5 box to build Fedora packages, the fedora build root configs would all have to be modified.  The command in question is ran /inside/ the buildroot, so it's not a matter of what host it's ran on, it's a matter of what contents are inside the buildroot.

Comment 6 Jesse Keating 2010-03-09 15:55:41 UTC
(In reply to comment #4)
> By the way createrepo_on_rpms could also be False by default, since it breaks
> setups where two concurrently running mocks share the same resultdir (not
> questioning the sanity of such setup, it's still a regression in behavior).    

Yeah, this wasn't well thought through on my part, I'm going to disable it by default at least in EL5, maybe the released Feodras too, and only leave it enabled on rawhide.

Comment 7 Fedora Update System 2010-03-11 22:28:13 UTC
mock-1.0.7-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/mock-1.0.7-1.el5

Comment 8 Fedora Update System 2010-03-12 03:39:26 UTC
mock-1.0.7-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mock-1.0.7-1.el5

Comment 9 Fedora Update System 2010-04-26 23:26:35 UTC
mock-1.0.7-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.