This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 571478 - ship ghc-utf8-string also for ghc-6.12.1
ship ghc-utf8-string also for ghc-6.12.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghc-utf8-string (Show other bugs)
13
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-03-08 11:11 EST by Jochen Schmitt
Modified: 2010-04-30 19:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: ghc-utf8-string-0.3.6-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 19:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2010-03-08 11:11:39 EST
Because the most current releases of ghc (F-13 and abouve) contains the ghc-utf8-string stuff, ghc should obsolete this package in a right way, so users can make a proper update to the new release of ghc without the usage of --nodeps.
Comment 1 Jens Petersen 2010-04-12 03:55:19 EDT
Thanks for the report: fixing in ghc-6.12.1-6.fc13.
Comment 2 Fedora Admin XMLRPC Client 2010-04-12 06:13:43 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Jens Petersen 2010-04-22 20:51:49 EDT
This build is still pending strange buildsystem errors for i686...
which I am looking into.
Comment 4 Jens Petersen 2010-04-23 06:55:54 EDT
Looks like the following build may succeed finally...
http://koji.fedoraproject.org/koji/taskinfo?taskID=2133662
Comment 5 Fedora Update System 2010-04-24 00:41:28 EDT
ghc-6.12.1-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ghc-6.12.1-6.fc13
Comment 6 Fedora Update System 2010-04-25 09:53:54 EDT
ghc-6.12.1-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ghc-6.12.1-6.fc13
Comment 7 Jens Petersen 2010-04-29 22:53:32 EDT
I am thinking perhaps it is better to bring back ghc-utf8-string
instead for F13 (it is already in devel for F14 since 6.12.2 does not
export utf8-string) and upstream says that the inclusion of
utf8-string in 6.12.1 was unintentional.
Comment 8 Jens Petersen 2010-04-29 22:56:08 EDT
(Additionally ghc-6.12 should be able to handle having two versions
of the same library system installed much better than 6.10.)
Comment 9 Fedora Update System 2010-04-30 02:01:50 EDT
ghc-utf8-string-0.3.6-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ghc-utf8-string-0.3.6-3.fc13
Comment 10 Fedora Update System 2010-04-30 19:45:39 EDT
ghc-utf8-string-0.3.6-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.