Bug 57151 - cd-rom devices will not work
Summary: cd-rom devices will not work
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cdrecord   
(Show other bugs)
Version: 7.2
Hardware: i586
OS: Linux
high
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-06 01:07 UTC by Karl F. Larsen
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 16:54:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karl F. Larsen 2001-12-06 01:07:18 UTC
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Karl F. Larsen 2001-12-06 13:19:51 UTC
I must have hit a dead time. Had all detail on the web page waiting for a
password....and when I finally got it it was all gone.

Intalled 7.2 workstation and the cdrom devices don't work. I have done a lot of
tests and got advice from the Grub developers and I can't get them to work. In
7.1 I'm using now the read-only and read/burn cdroms both work fine. 
The only thing remaining is to unplug the read/write cdrom and re-load 7.2 and
then try to install the read/write.

Comment 2 Karl F. Larsen 2001-12-06 13:24:50 UTC
When I use cdrecord -scandisk it correctly finds both cdrom devices. I assume it
will work. But the normal use of both cdroms is not there.

Comment 3 Karl F. Larsen 2001-12-06 23:56:14 UTC
Karl Larsen again. I deleted 7.2 from the /dev/hda3 partition and then re-loaded
it with only one cdrom connected. It loaded normally without any problems but
when it came up I tried a cdrom in the driver and nothing happened. Then I tried
mount /mnt/cdrom and it came back "no such block device". I then displayed with
ls -al /dev/cdrom and found it's linked to /dev/hdc as it should be.

It is my opinion now that there is either something wrong with the loader
program or there is a major bug in either the kernel or some other part off the
new system

Comment 4 Karl F. Larsen 2001-12-07 16:54:34 UTC
I got the new install of 7.2 working. I found that modules cdrom and ide-cd were
not being loaded on this version. I loaded them with modprobe and that got both
cdrom devices working. But not as well as under 7.1. 

I need to know what rc file loads these modules and I can explore more.

Comment 5 Mike A. Harris 2002-01-18 08:32:07 UTC
Bugzilla is for reporting bugs.  I dont see the problem you are having
as a bug, but rather as a technical support / configuration issue.
Please use our mailing lists for support questions like this.

Thanks.

Comment 6 Karl F. Larsen 2002-01-18 12:44:13 UTC
To get both the cd-rom reader and the cd-rom burner to work. I had to add
modprobe lines to rc.local. I can send you rc.local but not in this window. The
burner needs to appear as a scsi drive and I load that kernel driver with Grub.

Back when it was just loaded neither cd-rom worked but the ide-scsi kernel
driver was loaded. For sure it's a problem with the initial load and is "hard"
to fix if your not a skilled linux user.


Note You need to log in before you can comment on or make changes to this bug.