Bug 57157 - gtop: double-clicking a process pops up detail screen in asian character set
gtop: double-clicking a process pops up detail screen in asian character set
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gtop (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
: 61079 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-05 22:44 EST by Steve Listopad
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-04 23:17:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Listopad 2001-12-05 22:44:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I am running KDE.  When I select "System Monitor", or type gtop at a shell
prompt, I get the expected window showing processes.  But, if I
double-click a process, a window entitled, "Process 1234 Details" pops up.
 It has 3 sections, written in English:  Process State, Command Line, and
Process Credentials.  But, the details in each of these sections are
written in an asian character set, making them unreadable.

When trying to figure out what's going on, I discovered that at the login
window, you can specify the language you want for a session.  I picked
American English.  I was then told that American English was the default
anyway.  So, I guess that proves that I picked the right options when I
installed 7.2 ( I *DO* want American English as the language default).

The only other information that I can offer is that when I went to
redhat.com to update packages, some foreign langage packages were in the
list, and I chose to install everything (including the foreign languages).
 I don't know how this could hurt, since I'm still, as far  as I can tell,
defaulted to American English, but maybe it will be useful.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.get a shell prompt
2.type gtop
3.double-click any process to pop up the details window
	

Actual Results:  the details window has its information in an asian
character set.  note that the window that pops up when I type gtop at the
shell prompt is in American English, as expected.

Expected Results:  I should be seeing everything in English.

Additional info:
Comment 1 Steve Listopad 2002-01-04 22:58:17 EST
A service rep emailed me, saying that I should check xfs - and it IS running.
He also recommended checking the font paths via chkfntpath.  I did so, and 
noticed that Korean/Japanese fonts were at the beginning, so I moved them from 
the end, and now gtop works OK.

But, can you tell me what paths need to appear before others to guarantee that 
this problem will not occur again?

Thanks,
Steve
Comment 2 Havoc Pennington 2002-01-04 23:17:49 EST
It's a gtop bug that it gets the asian font - it shouldn't matter what order
your font path is in.
Comment 3 Havoc Pennington 2002-02-26 16:16:54 EST
Deferring, because new development is moving to GNOME 2 and
gnome-system-monitor, gtop will be going away eventually. Only critical bugfixes
on the GNOME 1.x codebase.
Comment 4 Havoc Pennington 2002-03-13 12:30:42 EST
*** Bug 61079 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.