Bug 571574 - virt-install fails: "ERROR monitor socket did not show up.: Connection refused"
virt-install fails: "ERROR monitor socket did not show up.: Connection ref...
Status: CLOSED DUPLICATE of bug 566425
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 571576 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-08 16:22 EST by Richard W.M. Jones
Modified: 2010-03-08 16:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-08 16:48:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-03-08 16:22:58 EST
Description of problem:

$ sudo virt-install -v -n F12x64 --accelerate -r 768 -f /dev/vg_thinkpad/F12x64 -l 'http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/releases/12/Fedora/x86_64/os/'


Starting install...
Retrieving file .treeinfo...                             | 2.4 kB     00:00 ... 
Retrieving file vmlinuz...                               | 6.5 MB     00:11 ... 
Retrieving file initrd.img...                            |  45 MB     01:20 ... 
ERROR    monitor socket did not show up.: Connection refused
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start F12x64'; otherwise, please
 restart your installation.
ERROR    monitor socket did not show up.: Connection refused
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 972, in <module>
    main()
  File "/usr/sbin/virt-install", line 834, in main
    start_time, guest.start_install)
  File "/usr/sbin/virt-install", line 896, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 795, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 896, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 1098, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: monitor socket did not show up.: Connection refused

The domain is not running:

$ sudo virsh list --all
 Id Name                 State
----------------------------------

Version-Release number of selected component (if applicable):

python-virtinst-0.500.2-1.fc13.noarch
libvirt-0.7.6-1.fc13.i686

How reproducible:

Happens once.  Second time I got a different bug, which I'm
going to file separately.
Comment 1 Richard W.M. Jones 2010-03-08 16:28:52 EST
The other bug is 571576.

In /var/log/libvirt/qemu/F12x64.log, I see the same thing each
time (for both bugs):

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-kvm -S -M fedora-13 -enable-kvm -m 768 -smp 1,sockets=1,cores=1,threads=1 -name F12x64 -uuid ebfaadbe-e908-ba92-fdb8-3fa2db557a42 -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/F12x64.monitor,server,nowait -mon chardev=monitor,mode=readline -no-reboot -boot c -kernel /var/lib/libvirt/boot/virtinst-vmlinuz.WDcnEp -initrd /var/lib/libvirt/boot/virtinst-initrd.img.TXxWIV -append method=http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/releases/12/Fedora/x86_64/os/ -drive file=/dev/vg_thinkpad/F12x64,if=none,id=drive-ide0-0-0,boot=on -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id
=ide0-0-0 -device virtio-net-pci,vlan=0,id=net0,mac=52:54:00:f4:f1:0a,bus=pci.0,
addr=0x4 -net tap,fd=42,vlan=0,name=hostnet0 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -vnc 127.0.0.1:0 -k en-gb -vga cirrus -device virti
o-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 
char device redirected to /dev/pts/1
qemu: could not load kernel '/var/lib/libvirt/boot/virtinst-vmlinuz.WDcnEp': Permission denied
Comment 2 Richard W.M. Jones 2010-03-08 16:33:26 EST
This is NOT an selinux problem.  I tried with selinux=Permissive.

However it does seem to be a simple permissions problem.  virt-install
downloads the files here:

# ls -alZ /var/lib/libvirt/boot/
drwx--x--x. root root system_u:object_r:virt_content_t:s0 .
drwxr-xr-x. root root system_u:object_r:virt_var_lib_t:s0 ..
-rw-------. root root unconfined_u:object_r:virt_content_t:s0 virtinst-vmlinuz.YWZ0KF

and qemu (running as the 'qemu' user) cannot access that file
because the permissions are 0600.

Is there some reason why this file should be 0600?  There is
no secret -- the kernel is a file downloaded off a public
internet site :-)
Comment 3 Richard W.M. Jones 2010-03-08 16:33:55 EST
*** Bug 571576 has been marked as a duplicate of this bug. ***
Comment 4 Richard W.M. Jones 2010-03-08 16:47:43 EST
Looks very similar to bug 516034.  Is this a regression?
Comment 5 Richard W.M. Jones 2010-03-08 16:48:54 EST
OK I see this is a dupe of bug 566425.

*** This bug has been marked as a duplicate of bug 566425 ***

Note You need to log in before you can comment on or make changes to this bug.