This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 571580 - Request branch of bouncycastle to EPEL5.
Request branch of bouncycastle to EPEL5.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bouncycastle (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 578099
  Show dependency treegraph
 
Reported: 2010-03-08 16:41 EST by Steve Traylen
Modified: 2010-04-01 17:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: bouncycastle-1.45-6.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-01 17:01:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
devel/bouncycastle.spec patch to allow building for EPEL5. (2.53 KB, patch)
2010-03-08 16:41 EST, Steve Traylen
no flags Details | Diff

  None (edit)
Description Steve Traylen 2010-03-08 16:41:39 EST
Created attachment 398631 [details]
devel/bouncycastle.spec patch to allow building for EPEL5.

Hi,
Attached is a patch to devel/bouncycastle.spec that allows it to be built
on EPEL5 as well. Tested within a mock build.

Please could you consider branching an EPEL5 build.

If you feel unable/unwilling to do so then in a week or so I'll make
the branch myself and maintain the EPEL build.

This patch also has a fix for the rawhide build.

BuildRequires:    java-devel >= 1.7
Requires:         java >= 1.7

should be 

BuildRequires:    java-devel >= 1:1.7
Requires:         java >= 1:1.7

http://fedoraproject.org/wiki/Packaging/Java#BuildRequires_and_Requires

  Steve
Comment 1 Orcan Ogetbil 2010-03-08 16:55:27 EST
Hi' I have been dealing with bouncycastle updates for the last year. I have no interest in EPEL, so go ahead. Ask for cvs.

As for the ">= 1.7". This does what we need it to do. It covers both icedtea and openjdk, leaving gcj out. So it was intentional. However since icedtea is obsolete now, it doesn't really matter what we put there anymore. See e.g.
   https://bugzilla.redhat.com/show_bug.cgi?id=463996#c12
(line ~20 and after)
Comment 2 Fedora Update System 2010-03-09 10:08:43 EST
bouncycastle-1.45-3.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/bouncycastle-1.45-3.el5
Comment 3 Fedora Update System 2010-03-10 06:17:12 EST
bouncycastle-1.45-6.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/bouncycastle-1.45-6.el5
Comment 4 Fedora Update System 2010-03-11 22:40:53 EST
bouncycastle-1.45-6.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bouncycastle'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bouncycastle-1.45-6.el5
Comment 5 Fedora Update System 2010-04-01 17:01:48 EDT
bouncycastle-1.45-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.