Bug 571854 - No way to create a new VM with an image stored in a non-default location?
Summary: No way to create a new VM with an image stored in a non-default location?
Keywords:
Status: CLOSED DUPLICATE of bug 557107
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-09 17:35 UTC by Zack Cerza
Modified: 2010-05-10 20:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-10 20:30:21 UTC
Type: ---


Attachments (Terms of Use)

Description Zack Cerza 2010-03-09 17:35:56 UTC
Description of problem:
I have been using ~/Virt/ to store my VM images. It appears virt-manager has changed, because I went to create a new VM and seem to be unable to choose both a custom location and a custom size for my VM.

In the "New VM" window, I can either choose the "Create a disk image on the computer's hard drive" option, which lets me choose a size but not a location, or I can choose the "Select managed or other existing storage" option, which presents a large window titled "Locate or create storage volume".

That window has an immutable list of "Storage Pools" with a single item ("default"). If I press the "New Volume" button, I'm presented with another dialog that won't allow me to create the image in any non-default location - I know this not because it specifies that, but because the free space shown is around what I think my root fs has - under 1GB. /home is on a different partition and has plenty of room.

If I press the "Browse Local" button, I'm presented with a file chooser titled "Locate Existing Storage". If I use that to browse to ~/Virt, it tries very hard to make me choose one of the existing images - but I don't want that, I want to create a new image for my new VM. If I Ctrl-click to deselect the existing image, and type in the name I want to use, and click "Open", everything but the "New VM" dialog closes. If I click "Forward" there, I see that the size of my possibly-to-be-created image is "1.0Gb".

Version-Release number of selected component (if applicable):
virt-manager-0.8.2-1.fc12.noarch

Comment 1 Cole Robinson 2010-05-10 20:30:21 UTC
Yes, I agree this UI is wonky. There is another bug tracking a simplification to the storage broswer that would allow creating a file image in an arbitrary location, and we will handle all the storage workings behind the scenes.

*** This bug has been marked as a duplicate of bug 557107 ***


Note You need to log in before you can comment on or make changes to this bug.