Bug 571869 - nvidia binary driver is broken and doesn't use DMA API correctly, leading to IOMMU faults
nvidia binary driver is broken and doesn't use DMA API correctly, leading to ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-09 13:30 EST by mapsonder
Modified: 2010-04-04 00:06 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-15 10:43:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mapsonder 2010-03-09 13:30:35 EST
Description of problem:

Since kernel upgrade machine freezes after Fedora progress bar before login.  Found DMA issue.  Workaround is kernel option iommu=soft.  For a newbie this would be a show stopper for using this version Linux on this big iron.

Version-Release number of selected component (if applicable):

kernel.x86_64 2.6.32.9-67.fc12

How reproducible:

100%

Steps to Reproduce:
1. Software Update to kernel 2.6.32.9-67.fc12, from 2.6.31.12-174.2.22.fc12, which was working.
2. Reboot.
  
Actual results:

Soon after initial Fedora progress bar goes to black screen, no login.

ssh in from other machine shows dmesg keeps repeating

DRHD: handling fault status reg 2
DMAR:[DMA Read] Request device [01:00.0] fault addr 215da0000
DMAR:[fault reason 01] Present bit in root entry is clear

Expected results:

Log in normally and use computer.

Additional info:

The akmod-nvidia.x86_64 195.36.08-1.fc12 that is installed works fine with kernel 2.6.31.12-174.2.22.fc12.

Workaround is on relevant kernel line, i.e. for 2.6.32.9-67.fc12, to append iommu=soft
Comment 1 David Woodhouse 2010-03-15 10:43:46 EDT
Closing NOTABUG. If you can reproduce without the broken nvidia module (i.e. if nouveau has similar problems), then please re-open.

Note You need to log in before you can comment on or make changes to this bug.