Bug 571910 - installation fails at kickstart option --fstype="btrfs"
Summary: installation fails at kickstart option --fstype="btrfs"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-09 20:08 UTC by Matej Nemcek
Modified: 2010-06-01 14:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-10 04:58:20 UTC


Attachments (Terms of Use)

Description Matej Nemcek 2010-03-09 20:08:09 UTC
Description of problem:
When I use these option in kickstart file:
part / --fstype="btrfs" --size=4000 or part / --fstype="btrfs" -size=1 --grow
installation fails.

Version-Release number of selected component (if applicable):
anaconda 13.32

How reproducible:
Install F13-Alpha from kickstart.

Steps to Reproduce:
1. Use in kickstart part / --fstype="btrfs" --size=4000
2. Boot installation from ks=http://server/kickstart
3. Switch to the debug console (ctrl+alt+f3) 
  
Actual results:
ERROR anaconda: insufficient disk space: installing package nspr-4.8.4-1.1.fc13.i686 needs 211MB on the / filesystem
...
ERROR anaconda: insufficient disk space: installing package kernel-PAE-2.6.33-1.fc13.i686 needs 528MB on the / filesystem
INFO anaconda: (/, 553365504)

Expected results:
Proper install root of system on btrfs.

Additional info: This bug was also at anaconda 12.28 (f12-constatine)

Comment 1 Chris Lumens 2010-03-09 20:11:34 UTC
The error messages you're getting don't really have anything to do with --fstype=btrfs.  It's telling you that you're trying to install too much stuff into too small of a partition.  What happens if you either increase the size of / or decrease the number of packages you're installing?

The only way this would have something to do with --fstype=btrfs is if you change it to --fstype=ext4 and it works.

Comment 2 Matej Nemcek 2010-03-09 20:33:44 UTC
Well, that partition is 7GB. I think it's enough at minimal installation. Yes, with --fstype=ext4 installation works from kickstart. Is --fstype=btrfs officially supported? Or how to install system root at btrfs from kickstart?

Comment 3 Chris Lumens 2010-03-09 20:52:25 UTC
part / --fstype="btrfs" --size=4000

makes a partition that's 4 GB, not 7 GB.  Which are you actually doing?  Please attach your complete kickstart file to this bug report.

btrfs is supported as long as you provide the "btrfs" command line option, as it's not quite ready for mainstream use yet.

Comment 4 Matej Nemcek 2010-03-09 21:07:56 UTC
I just wanna say, that I raised to --size=7000, but I recieve same error.

firewall --enabled --ssh
install
cdrom
repo --name=my-everything --mirrorlist=http://mirrors.fedoraproject.org/metalink?repo=fedora-13-Alpha&arch=i386
repo --name=my-updates --mirrorlist=http://mirrors.fedoraproject.org/metalink?repo=updates-testing-f13-Alpha&arch=i386
rootpw --iscrypted $1$tZ8uWXUF$lJm8YB9z/pTHFBA7.HpUV/
auth  --useshadow  --passalgo=sha512
text
keyboard us
lang en_US
selinux --disabled
skipx
logging --level=info
reboot
timezone  Etc/GMT+1
bootloader --location=mbr
zerombr
clearpart --all  
part /boot --fstype="ext4" --size=200
part swap --fstype="swap" --size=256 
part / --fstype="btrfs" --size=7000

But tell me, how to use proper btrfs option in kickstart?

Comment 5 Chris Lumens 2010-03-09 21:11:20 UTC
As I previously stated:  btrfs is supported as long as you provide the "btrfs" command line option, as it's not quite ready for mainstream use yet.

Did you make sure to add that as an option when you booted anaconda?

Comment 6 Matej Nemcek 2010-03-09 23:53:56 UTC
Oh, I'm blind today.
Also, should be included btrfs option as experimental at http://fedoraproject.org/wiki/Anaconda/Options 
Installation sucess.
Thanks.

Comment 7 Chris Lumens 2010-03-10 04:58:20 UTC
Great, glad it's working out for you.  Thanks for retesting.

Comment 8 Valent Turkovic 2010-05-29 13:43:41 UTC
Setting up a separate /boot partition is essential because if you just switch / partition from ext4 to btrfs you get an error. Btrfs doesn't support booting from it.
Also hope this blog post helps:
http://kernelreloaded.blog385.com/index.php/archives/btrfs-fedora-remix/

Comment 9 Valent Turkovic 2010-05-29 20:15:55 UTC
Could anybody give an example of working kickstart file that creates brtfs livecd iso image?

I tried few examples and they all create only ext3 iso images :(

Here is what I tried:

part /boot –size=128 –onpart=sda1 –fstype=ext3
part pv.01 –size=128 –onpart=sda2 –grow
volgroup VolGroup pv.01
logvol / –size=128 –vgname=VolGroup –fstype=btrfs –grow –name=root –fsoptions=ssd

and more simple one:

part /boot --size 120 --fstype ext4
part / --size 6000 --fstype="btrfs"
bootloader --location=mbr --append=btrfs


None of these options create btrfs iso image. Any idea why?

Comment 10 Valent Turkovic 2010-05-30 10:51:47 UTC
Should I clone this bug as a new one or will this one be reopened?

Comment 11 Chris Lumens 2010-06-01 14:00:56 UTC
You'd need to ask the livecd-tools people that.  We're not responsible for that code.


Note You need to log in before you can comment on or make changes to this bug.