Bug 572024 - ksh process substitution is broken
ksh process substitution is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ksh (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-09 21:14 EST by Jeff Frontz
Modified: 2010-04-09 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: ksh-20100309-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-26 20:55:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Frontz 2010-03-09 21:14:42 EST
Description of problem:

Attempts to use process substitution result in a "syntax error".

Version-Release number of selected component (if applicable):

ksh-20100202-1.fc12.x86_64 (Version JM 93t+ 2010-02-02)

How reproducible:

Extremely easily reproducible.

Steps to Reproduce:
1. Fire up a korn shell (ksh)
2. Type "cat <(echo yay)"


Actual results:

I get "-ksh: syntax error: `)' unexpected"
  

Expected results:

If it works, you should see "yay".

Additional info:

I don't think this is an inherent problem with the libraries or kernel, as I copied an older version of ksh (Version M 93s+ 2008-01-31 of FC7 vintage) and the process substitution worked just fine.
Comment 1 Michal Hlavinka 2010-03-10 07:32:24 EST
this is odd, I can reproduce this bug with ksh-20100202-1.fc12.x86_64 but can't reproduce it with local build

a)some patch breaks this
b)some hidden buildrequire

looking into this...
Comment 2 Michal Hlavinka 2010-03-10 09:42:40 EST
b) is correct and it's pretty well hidden, I've tried to specify ALL -devel packages I have as buildrequires and it still does not work. It was broken with mock containing older libraries then on my system (reported package) and is broken with actual mock (scratch rebuild), so problem is not caused by package version differencies. ldd shows no differencies, build log shows no differencies and also strace shows nothing usable. Still, something is different here

I need to experiment little more.
Comment 3 Michal Hlavinka 2010-03-10 10:26:36 EST
and the winner is...

mock chroot

this feature is enabled only if /dev/fd/ directory exists and works as expected.

Tested with following command:

ls /dev/fd/9 9<&0 >/dev/null 2>&1

but it does not work in chroot.

building fix...
Comment 4 Michal Hlavinka 2010-03-10 11:00:08 EST
fixed since ksh-20100309-1.fc12

detection of /dev/fd/X was changed to /proc/self/fd/X which works in mock
Comment 5 Fedora Update System 2010-03-10 11:23:39 EST
ksh-20100309-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ksh-20100309-1.fc12
Comment 6 Fedora Update System 2010-03-10 11:23:44 EST
ksh-20100309-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ksh-20100309-1.fc13
Comment 7 Fedora Update System 2010-03-10 11:23:48 EST
ksh-20100309-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ksh-20100309-1.fc11
Comment 8 Fedora Update System 2010-03-11 08:23:57 EST
ksh-20100309-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ksh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ksh-20100309-1.fc13
Comment 9 Fedora Update System 2010-03-11 23:19:35 EST
ksh-20100309-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ksh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ksh-20100309-1.fc11
Comment 10 Fedora Update System 2010-03-11 23:29:13 EST
ksh-20100309-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ksh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ksh-20100309-1.fc12
Comment 11 Fedora Update System 2010-03-26 20:55:42 EDT
ksh-20100309-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-03-26 21:03:40 EDT
ksh-20100309-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-04-09 00:15:16 EDT
ksh-20100309-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.