Bug 57207 - no information on how to add -i option for postgresql in 7.2
no information on how to add -i option for postgresql in 7.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-06 15:32 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 15:32:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-06 15:32:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
postgresql's package on redhat7.2 by default does not listen on tcp ports. 
This is confusing to people with 7.1 experience, because the -i option is 
enabled there by default. The postgresql service startup process is not 
documented at all, which makes this problem hard to troubleshoot for 
someone new to LINUX. The difference between the packages is 
that /var/lib/pgsql/data/postmaster.opts.default file is not created in 
the 7.2 distribution (on 7.1 it is). This is very confusing to people 
migrating from 7.1 to 7.2. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install postgresql
2. type service postgresql start
3. type fuser -n tcp 5432
4. (no process will be listening)
5. type vi /var/lib/pgsql/data/postmaster.opts.default
6. in the text file add the line -i
7. save the file
8. 
9. postgresql is now properly enabled to listen on incoming TCP connections


	

Actual Results:  postgresql was not listening on port 5432

Expected Results:  postgresql had tcp connections enabled with -i switch 
in 7.1

Additional info:

The postgresql startup process is complicated and involves several 
files: /etc/rc.d/init.d/postgresql and /usr/bin/pg_ctl
you should document somewhere how to properly add -i to the startup 
options in the documentation. This is very hard to find for a new user, 
even with a howto.
Comment 1 David Lawrence 2001-12-06 15:49:32 EST
You enable networking support by uncommenting the proper lines in
/var/lib/pgsql/data/postgresql.conf. You can also enable SSL support as well as
custom port number.
Comment 2 Need Real Name 2001-12-06 16:24:44 EST
the /var/lib/pgsql/data/postgresql.conf you mention does not exist in this 
location on my machine. I'm using redhat 7.2 with ximian gnome desktop and 
installed the postgresql-7.0.3-8 rpm through redcarpet.
Comment 3 Trond Eivind Glomsrxd 2001-12-06 16:40:17 EST
These packages are not what we ship - we ship postgresql 7.1 with RHL 7.2

Note You need to log in before you can comment on or make changes to this bug.