Bug 572094 - [virt-manager][rawvirt] hotswap of cdrom doesn't work anymore
[virt-manager][rawvirt] hotswap of cdrom doesn't work anymore
Status: CLOSED DUPLICATE of bug 582005
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-10 04:13 EST by Soeren Grunewald
Modified: 2010-05-18 12:14 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 12:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager log during dvd rom iso swap (7.94 KB, application/octet-stream)
2010-04-05 13:35 EDT, Anthony Spinillo
no flags Details

  None (edit)
Description Soeren Grunewald 2010-03-10 04:13:46 EST
Description of problem:


Version-Release number of selected component (if applicable):
packages from rawvirt
virt-manager-0.8.3-1.fc12.noarch

libvirt-0.7.6-1.fc12.x86_64
qemu-common-0.12.3-4.fc12.x86_64
qemu-img-0.12.3-4.fc12.x86_64
qemu-kvm-0.12.3-4.fc12.x86_64
qemu-system-x86-0.12.3-4.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1. open details dialog for running vm (kvm)
2. select cdrom device
3. choose a iso from pool
  
Actual results:
Informational dialog that change will be made on next vm restart

Expected results:
vm can access insert iso

Additional info:
going back to virt-manager-0.8.2-1.fc12.noarch solves the issue
all other packages are still rawvirt

using virt-manager from rawvirt and libvirt/qemu from f12 does not solve the issue.
Comment 1 Cole Robinson 2010-04-05 12:24:58 EDT
This should be fixed by virt-manager 0.8.4 which should be in rawvirt. Closing as CURRENTRELEASE. 

If you can still reproduce with the latest packages, please reopen, and provide ~/.virt-manager/virt-manager.log.
Comment 2 Anthony Spinillo 2010-04-05 13:34:16 EDT
I updated to latest 0.8.4. Virt-Manager connects DVD ISO file to running guest (XP) now and does not say changes will be made on next vm restart. "Apply" button is grayed out though. The XP guest does not indicate that a dvd has been inserted though.

Clicking cdrom icon on XP guest, results in "Insert CD Now" message in XP.
If I reboot guest with ISO connected, it sees the DVD, but if I eject it in XP and reconnect in virt-manager, XP does not notice it.

Same results with a Fedora 12 guest.

Host is Fedora 12 running:
libvirt-0.7.7-2.fc12.x86_64
virt-viewer-0.2.1-1.fc12.x86_64
python-virtinst-0.500.2-1.fc12.noarch
libvirt-python-0.7.7-2.fc12.x86_64
libvirt-client-0.7.7-2.fc12.x86_64
virt-manager-0.8.4-1.fc12.noarch
qemu-kvm-0.12.3-6.fc12.x86_64
qemu-user-0.12.3-6.fc12.x86_64
qemu-0.12.3-6.fc12.x86_64
qemu-common-0.12.3-6.fc12.x86_64

I will attach ~/.virt-manager/virt-manager.log
Comment 3 Anthony Spinillo 2010-04-05 13:35:30 EDT
Created attachment 404524 [details]
virt-manager log during dvd rom iso swap

See above bug report.
Comment 4 Cole Robinson 2010-04-15 08:47:56 EDT
Sounds like this is a libvirt bug with latest qemu. Patch available for libvirt upstream:

https://www.redhat.com/archives/libvir-list/2010-April/msg00692.html

Probably want to backport this to F13 if applicable.
Comment 5 Cole Robinson 2010-05-18 12:14:27 EDT

*** This bug has been marked as a duplicate of bug 582005 ***

Note You need to log in before you can comment on or make changes to this bug.