Bug 572137 - Networkmanager can no longer find secrets service
Networkmanager can no longer find secrets service
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
: 575914 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-10 06:53 EST by Stefan Becker
Modified: 2015-03-03 17:45 EST (History)
13 users (show)

See Also:
Fixed In Version: gnome-keyring-2.30.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 19:55:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to change dbus name (448 bytes, patch)
2010-04-29 09:24 EDT, Thomas Spura
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 610715 None None None Never
GNOME Desktop 611002 None None None Never

  None (edit)
Description Stefan Becker 2010-03-10 06:53:18 EST
Description of problem:

After preupgrading from Fedora 12 to Fedora 13, NetworkManager always asks for WLAN secrets. I'm using KDE, not GNOME, but previously gnome-keyring-daemon has provided those secrets.

Version-Release number of selected component (if applicable):
dbus-1.2.20-1.fc13.i686
gnome-keyring-2.29.90-2.fc13.i686
NetworkManager-0.8.0-0.4.git20100211.fc13.i686


How reproducible:
Always

Steps to Reproduce:
1. login to KDE
2. start nm-applet
3. connect to a protected WLAN
  
Actual results:
NM asks for passwords

Expected results:
NM should be able to get secrets from gnome-keyring-daemon

Additional info:
When I start nm-applet in a terminal I see these messages:

** Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files

but when I search dbus files I see only this:

$ find /usr/share/dbus-1/ -type f | xargs fgrep secrets
/usr/share/dbus-1/services/org.gnome.keyring.service:Exec=/usr/bin/gnome-keyring-daemon --start --foreground --components=secrets

Should NM fall back to org.gnome.keyring if org.freedesktop.secrets fails?
Comment 1 Stefan Becker 2010-03-10 06:56:11 EST
FYI: I changed /usr/share/dbus-1/services/org.gnome.keyring.service to read

[D-BUS Service]
#Name=org.gnome.keyring
Name=org.freedesktop.secrets

and now it NM gets it's passwords again...
Comment 2 Christoph Wickert 2010-04-26 06:23:38 EDT
Dan, it would be nice if you could apply the fix because it affects Xfce and LXDE as well and we really need the keyring daemon there.
Comment 3 Dan Williams 2010-04-26 18:27:03 EDT
NM doesn't really have anything to do with this, it just uses the gnome-keyring libraries which happen to use D-Bus these days.  So the problem is likely in gnome-keyring itself; moving to there.

For gnome-keyring maintainer: I'm not sure what the problem is here in the gnome-keyring code, but a D-Bus service can hold as many bus names as it wants, so the gnome-keyring daemon could claim *both* org.gnome.keyring and org.freedesktop.secrets, and then you install two separate service activation files, one for each service name, and stuff should work as expected.
Comment 4 Thomas Spura 2010-04-29 09:24:22 EDT
Created attachment 410107 [details]
patch to change dbus name

(In reply to comment #1)
> FYI: I changed /usr/share/dbus-1/services/org.gnome.keyring.service to read
> 
> [D-BUS Service]
> #Name=org.gnome.keyring
> Name=org.freedesktop.secrets
> 
> and now it NM gets it's passwords again...    

Works here too.

Attached is a patch, that can be applied to the version currently in CVS.

When trying so, I also noted, that there is a rpath issue and I need to add the snipped from:
https://fedoraproject.org/wiki/Packaging/Guidelines#Removing_Rpath
Comment 5 Rex Dieter 2010-04-30 11:17:38 EDT
If both dbus names are required for proper function, +1 to Dan's suggestions in comment #3
Comment 6 Christoph Wickert 2010-05-01 11:52:41 EDT
Tomáš, this is vitally important for the Xfce and LXDE spin, not sure about KDE. What are your plans here?
Comment 7 Stefan Becker 2010-05-01 13:55:09 EDT
This is important for KDE too. Last time I tested knetworkmanager it was still not functional, i.e. for now your are stuck with NetworkManager-gnome on a KDE install.
Comment 8 Rex Dieter 2010-05-01 14:23:41 EDT
slightly offtopic, but I'm also curious to know why the org.freedesktop.* namespace is being used here?  Is there a xdg secrets spec so that other providers can conform to it?
Comment 9 Tomáš Bžatek 2010-05-03 10:08:58 EDT
*** Bug 575914 has been marked as a duplicate of this bug. ***
Comment 10 Tomáš Bžatek 2010-05-03 10:09:32 EDT
Bug 575914 refers to the same issue, which I'm going to close as a duplicate now. My findings were that the desktop file limits daemon autostarts only to Gnome and LXDE while users were running XFCE and others. This is also an upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=610715 (plus https://bugzilla.gnome.org/show_bug.cgi?id=593772 explaining the "dead" gnome-keyring-daemon processes within the session and not cleaning themselves).
Comment 11 Rex Dieter 2010-05-03 11:24:50 EDT
ok, seems to be (partially) bug #453880 all over again

yes, kick out the OnlyShowIn please, marking as blocker.
Comment 12 Tomáš Bžatek 2010-05-03 11:33:04 EDT
I've backported two patches from upstream, see https://bugzilla.gnome.org/show_bug.cgi?id=611002

I originally thought the org.freedesktop.secrets dbus node is going to become a standardized way for secret storage service with differrent implementations in particular desktop environments. But looks like this is not going to happen in near future (heard rumours about KWallet providing the same functionality in the future) and certainly not yet for F13.
Comment 13 Fedora Update System 2010-05-03 11:42:48 EDT
gnome-keyring-2.30.1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnome-keyring-2.30.1-2.fc13
Comment 14 Adam Williamson 2010-05-03 21:59:51 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Fedora Update System 2010-05-04 02:11:06 EDT
gnome-keyring-2.30.1-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-keyring'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gnome-keyring-2.30.1-2.fc13
Comment 16 Adam Williamson 2010-05-04 19:02:16 EDT
Tomasz, the update has the necessary karma to be sent to stable - can you please submit it to stable? Thanks.
Comment 17 Thomas Spura 2010-05-04 19:32:34 EDT
(In reply to comment #16)
> Tomasz, the update has the necessary karma to be sent to stable - can you
> please submit it to stable? Thanks.    

I thought a critical path update requires one karma from a proventester and one by a non-proventester and then it's directly submitted to stable automatically...

Or can this be turned of by disabling karma automatism?
Comment 18 Fedora Update System 2010-05-04 19:55:03 EDT
gnome-keyring-2.30.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Rahul Sundaram 2010-05-08 18:55:29 EDT
(In reply to comment #8)
> slightly offtopic, but I'm also curious to know why the org.freedesktop.*
> namespace is being used here?  Is there a xdg secrets spec so that other
> providers can conform to it?    

Yes.  http://www.freedesktop.org/wiki/Specifications/secret-storage-spec

Note You need to log in before you can comment on or make changes to this bug.