Bug 57214 - mozilla segfaults when run as root or for some(not all) users
mozilla segfaults when run as root or for some(not all) users
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-06 17:22 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 17:37:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-06 17:22:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
mozilla works fine for user A.
For roor and user B, it segfaults on start.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run mozilla as root or user B
2.mozilla segfaults
3.
	

Actual Results:  [root@yakuza root]# mozilla 
Segmentation fault


Expected Results:  mozilla should have worked

Additional info:

[root@yakuza root]# rpm -qa | grep mozilla
mozilla-js-debugger-0.9.6-0
nautilus-mozilla-1.0.6-1
kdebindings-kmozilla-2.2-2
mozilla-mail-0.9.6-0
mozilla-psm-0.9.6-0
mozilla-0.9.6-0
Comment 1 Need Real Name 2001-12-06 17:37:33 EST
I couldn't do mozilla -g -d gdb (It wouldn't even get into gdb because of the 
segfault.) So I tried running mozilla-bin directly inside gdb, without the
wrapper script. Now I can get a backtrace. Hope this is useful.

[root@yakuza root]# gdb /usr/lib/mozilla/mozilla-bin 
GNU gdb Red Hat Linux (5.1-1)
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) run
Starting program: /usr/lib/mozilla/mozilla-bin 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 1024
(LWP 10522)]
[New Thread 2049 (LWP 10524)]
[New Thread 1026 (LWP 10525)]
[New Thread 2051 (LWP 10526)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 10522)]
__pthread_mutex_lock (mutex=0x85edefe8) at mutex.c:99
99
mutex.c: No such file or directory.
	in mutex.c
(gdb) where
#0  __pthread_mutex_lock (mutex=0x85edefe8) at mutex.c:99
#1  0x4052ecc8 in __libc_free (mem=0x405e2a18) at malloc.c:3152
#2  0x401c3444 in PL_strfree () from /usr/lib/libplc4.so
#3  0x4124d688 in NSGetModule ()
   from /usr/lib/mozilla/components/libgkplugin.so
#4  0x4124451a in NSGetModule ()
   from /usr/lib/mozilla/components/libgkplugin.so
#5  0x412449bc in NSGetModule ()
   from /usr/lib/mozilla/components/libgkplugin.so
#6  0x412439b4 in NSGetModule ()
   from /usr/lib/mozilla/components/libgkplugin.so
#7  0x41222cd7 in NSGetModule () from /usr/lib/mozilla/components/liboji.so
#8  0x412238fd in NSGetModule () from /usr/lib/mozilla/components/liboji.so
#9  0x41227803 in NSGetModule () from /usr/lib/mozilla/components/liboji.so
#10 0x410f2701 in NSGetModule () from /usr/lib/mozilla/components/libjsdom.so
#11 0x410f2334 in NSGetModule () from /usr/lib/mozilla/components/libjsdom.so
#12 0x410f294d in NSGetModule () from /usr/lib/mozilla/components/libjsdom.so
#13 0x410ec8dd in NSGetModule () from /usr/lib/mozilla/components/libjsdom.so
#14 0x410d2b5c in NSGetModule ()
   from /usr/lib/mozilla/components/libdocshell.so
#15 0x410d3f06 in NSGetModule ()
   from /usr/lib/mozilla/components/libdocshell.so
#16 0x401620e4 in nsGetInterface::operator() () from /usr/lib/libxpcom.so
#17 0x4018ca32 in nsCOMPtr_base::assign_from_helper ()
   from /usr/lib/libxpcom.so
#18 0x4073bb26 in NSGetModule ()
   from /usr/lib/mozilla/components/libnsappshell.so
#19 0x4073b3d6 in NSGetModule ()
   from /usr/lib/mozilla/components/libnsappshell.so
#20 0x08051fde in nsWindowCreator::CreateChromeWindow ()
#21 0x406b4eaa in NSGetModule ()
   from /usr/lib/mozilla/components/libembedcomponents.so
#22 0x406b425e in NSGetModule ()
   from /usr/lib/mozilla/components/libembedcomponents.so
#23 0x406b3d78 in NSGetModule ()
   from /usr/lib/mozilla/components/libembedcomponents.so
#24 0x406b2f2d in NSGetModule ()
   from /usr/lib/mozilla/components/libembedcomponents.so
#25 0x406b1e7e in NSGetModule ()
   from /usr/lib/mozilla/components/libembedcomponents.so
#26 0x408cc665 in NSGetModule () from /usr/lib/mozilla/components/libprofile.so
#27 0x408cdaad in NSGetModule () from /usr/lib/mozilla/components/libprofile.so
#28 0x408c9f7c in NSGetModule () from /usr/lib/mozilla/components/libprofile.so
#29 0x4073ad6b in NSGetModule ()
   from /usr/lib/mozilla/components/libnsappshell.so
#30 0x0804fdfd in NS_CreateNativeAppSupport ()
#31 0x08051095 in NS_CreateNativeAppSupport ()
#32 0x08051c1b in main ()
#33 0x404ca627 in __libc_start_main (main=0x8051ad0 <main>, argc=1, 
    ubp_av=0xbffffa74, init=0x804bf40 <_init>, fini=0x8052b40 <_fini>, 
    rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbffffa6c)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 
Comment 2 Christopher Blizzard 2002-01-25 15:07:56 EST
Works for me.

Note You need to log in before you can comment on or make changes to this bug.