Bug 572148 - Traceback when trying to update to Fedora 13 Alpha
Traceback when trying to update to Fedora 13 Alpha
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-10 07:17 EST by Milan Kerslager
Modified: 2010-05-03 12:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: preupgrade-1.1.5-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 12:13:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preupgrade log (2.66 KB, text/plain)
2010-04-14 12:13 EDT, Kamil Páral
no flags Details

  None (edit)
Description Milan Kerslager 2010-03-10 07:17:44 EST
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 240, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 525, in main_preupgrade
    problems = self.pu.downloadPkgs(downloadpkgs)                 
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1420, in downloadPkgs
    self.plugins.run('predownload', pkglist=pkglist)
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 177, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/presto.py", line 581, in predownload_hook
    (problems, more) = downloadPkgs(conduit, pinfo, download_pkgs)
  File "/usr/lib/yum-plugins/presto.py", line 421, in downloadPkgs
    cb.start(text=text, size=rebuild_size)
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 758, in start
    self.updateProgress(basename,0.0,'','')
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 725, in updateProgress
    if name.endswith('.rpm'):
AttributeError: 'NoneType' object has no attribute 'endswith'
Comment 1 Kamil Páral 2010-04-14 12:13:15 EDT
Created attachment 406560 [details]
preupgrade log

I have just seen the same exception for preupgrade-1.1.4-1.fc12. The full log is attached.

I don't know what exactly caused it, but I suspect that that particular mirror was outdated and some packages may have been missing there. May using metalink when choosing mirrors would ensure the mirror is not outdated?

Also a scary thing is that after the exception the preupgrade window showed "success, please reboot" content. It should not certainly report success after program crash.
Comment 2 Kamil Páral 2010-04-14 13:35:44 EDT
I tried that on a clean system again, and it happened again. Running preupgrade again helps and it is not that big issue. But having preupgrade report success a asking for reboot is bigger problem. Should this be a F13 blocker?
Comment 3 Kamil Páral 2010-04-14 13:39:32 EDT
According to adamw's guidance marking as F13 Blocker.
Comment 4 Richard Hughes 2010-04-16 07:16:08 EDT
Could you try the preupgrade package here please: http://people.freedesktop.org/~hughsient/fedora/13/i386/
Comment 5 Kamil Páral 2010-04-16 08:30:08 EDT
(In reply to comment #4)
> Could you try the preupgrade package here please:
> http://people.freedesktop.org/~hughsient/fedora/13/i386/    

Please provide x86_64 package. Also I have seen this bug on x86_64 architecture, so I can't just confirm the fix using i386 arch.

By the way, shouldn't this package be built for F12? Because this bug happened when using F12's preupgrade to upgrade to F13.
Comment 6 Kamil Páral 2010-04-16 09:02:14 EDT
I have followed the exact procedure where the 1.1.4 version crashed for me and 1.1.5 version seems to have no problem at all. I think we can consider this as fixed. Good job.
Comment 7 Adam Williamson 2010-04-16 16:32:06 EDT
richard, will you be submitting 1.1.5 as an update for f13 soon?

discussed at the blocker meeting today, we accepted this as a blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Alex Lancaster 2010-04-23 03:46:36 EDT
(In reply to comment #7)
> richard, will you be submitting 1.1.5 as an update for f13 soon?

Also need an F-12 update to be able to update from F-12 -> F-13, obviously... ;)
Comment 9 Adam Williamson 2010-04-23 15:21:12 EDT
Discussed at today's blocker meeting. Richard, when do you plan to submit this fix to F12 updates? It's still blocking the release of F13 until that happens. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Richard Hughes 2010-04-25 05:42:49 EDT
(In reply to comment #9)
> when do you plan to submit

Monday morning. I'm away from home this weekend, so I'll do it as soon as I'm back. Thanks.
Comment 11 Fedora Update System 2010-04-26 07:26:53 EDT
preupgrade-1.1.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/preupgrade-1.1.5-1.fc12
Comment 12 Fedora Update System 2010-04-26 22:18:15 EDT
preupgrade-1.1.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/preupgrade-1.1.5-1.fc12
Comment 13 Fedora Update System 2010-05-03 12:13:07 EDT
preupgrade-1.1.5-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.