Bug 57215 - Unable to specify new SCSI or network card when performing a linux expert installation
Unable to specify new SCSI or network card when performing a linux expert ins...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-06 18:15 EST by Richard Black
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 18:15:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Black 2001-12-06 18:15:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; compaq)

Description of problem:
The menu that existed in RH70 and prior is not accessible if you 
enter "linux expert" mode of installation.  This appears to be dependent 
on whether it can find your cd-rom or not.  So you end up with the 
installer finding your CD-Rom, but not being able to find your hard drives 
(in the case of the EISA based Compaq Array controllers where the address 
muste be specified).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from floppy on a PL1500 with an Original Smart Array controller 
(any EISA based card will do which you will have to specify the memory 
address).  This controller contains the drives to perform installation 
to.  CD-Rom is located on embedded SCSI.
2. Enter "linux expert" mode during installation
3. Continue install.
	

Actual Results:  Installer aborts because it could not find any drives to 
install to.

Expected Results:  Installer should have showm me the "Add SCSI or Network 
Card" listing.  I should then be able to add options when loading the 
cpqarray driver.

Additional info:

It appears that since the installer can find the CD-Rom, that it doesn't 
bother to show the "Add SCSI or Netowrk Card" menu.  This seems to be the 
same in RH71 and RH72.
Comment 1 Jeremy Katz 2001-12-12 15:15:59 EST
To add drivers for ISA cards, you have to boot with 'linux isa' as of Red Hat
Linux 7.1 and later as documented in the Installation Guide.
Comment 2 Richard Black 2001-12-12 15:59:13 EST
That's very nice, I'll add it to my installation notes. I don't understand why 
that functionality isn't available in (i.e. was removed from) both "linux dd" 
and "linux expert".  This has caused many aborted installations over the last 
several months.  I am even sure that some gave up on trying.

Note You need to log in before you can comment on or make changes to this bug.