Bug 57221 - initscripts and sulogin do not accept password correctly
initscripts and sulogin do not accept password correctly
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: SysVinit (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-12-06 23:26 EST by bk299
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-12-06 23:27:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description bk299 2001-12-06 23:26:57 EST
Description of Problem:
With the following line in /etc/inittab
sulogin does not correctly accept the input passwords or CTRL-D when init 1
or init S are invoked.  From this point on, the only way to do anything
usable is to reboot and I haven't checked to see if it will take a password
when booting into single user mode.

Version-Release number of selected component (if applicable):

How Reproducible:
place above line in inittab, goto userlevel 1 or S, problem should be
immediately apparent.

Steps to Reproduce:
1. init 1
2. sulogin then prompts for password
3. declares any input password to be invalid, does not accept CTRL-D

Actual Results:
declares password invalid, re-prompts.  If you put a space infront of your
password it will dump you out to a useless shell prompt.

Expected Results:
Expected to log in single user mode after being prompted for root password

Additional Information:
not at the moment...
Comment 1 Bill Nottingham 2001-12-13 12:36:07 EST
This should be fixed with the 2.11f-17 util-linux update.

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.