Bug 57228 - Upgrade to Red Hat 7.2 fails on system running 7.0
Upgrade to Red Hat 7.2 fails on system running 7.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-07 06:16 EST by Toralf
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/scsi/scsi (335 bytes, text/plain)
2001-12-13 03:16 EST, Toralf
no flags Details
/proc/partitions (337 bytes, text/plain)
2001-12-13 03:18 EST, Toralf
no flags Details
/proc/scsi/modules (967 bytes, text/plain)
2001-12-13 03:20 EST, Toralf
no flags Details

  None (edit)
Description Toralf 2001-12-07 06:16:40 EST
Description of Problem:
Installation of Red Hat Linux 7.2 fails on one of our systems which is
happily running Red Hat 7.0 today. The harware is:

Mainboard: Asus PDB-DS
Disk: Seagate ST16403LW (36Gb Cheetah)
SCSI controller: Tekram DC-390 U2B or on-board Adaptec AIC-7890; have tried
connecting the disk to both, whith the same result


How Reproducible:
Every time


Steps to Reproduce:
1. Start installer; I'm assuming you know how. 
2. Select "Custom" or "Upgrade Existing System" 
3. Select "Disk Druid" for "Custom" partitions.

Actual Results:
"Upgrade Existing System" says:

You don't have any Linux partitions. You can't
upgrade this system

"Custom" says:

An error has occured - no valid devices
were found on which to create new
filesystems. Please check you hardware
for the cause of this problem.


Expected Results:
Installation started.


Additional Information:
If I go to VC-2, I can access the root file system by doing:

# mknod /dev/sda6 b 8 6
# mount /dev/sda6 <somewhere>

Note that the disk was NOT automatically mounted on /mnt/sysimage.

THE MOST IMPORTANT QUESTION:
As you can see, I know *everything* there is to know about the disk and its
file systems. WHY CAN'T THE INSTALLER LET ME TELL IT WHAT IT DOESN'T FIND
OUT AUTOMATICALLY???
Comment 1 Jeremy Katz 2001-12-12 15:13:26 EST
Can you get the output of /proc/scsi/scsi, /proc/partitions, and /proc/modules
from the installer environment by copying them to a floppy from the shell on
tty2 and attach them to this bug report?
Comment 2 Toralf 2001-12-13 03:16:57 EST
Created attachment 40468 [details]
/proc/scsi/scsi
Comment 3 Toralf 2001-12-13 03:18:47 EST
Created attachment 40469 [details]
/proc/partitions
Comment 4 Toralf 2001-12-13 03:20:46 EST
Created attachment 40470 [details]
/proc/scsi/modules
Comment 5 Toralf 2001-12-13 03:28:05 EST
The requested files have been attached.

Once again, note that I have tried various different variants of the SCSI setup;
I have disabled the Adaptec, removed the Tekram and connected the disk to the
Adaptec, disconnected the CD-ROM etc. (and started installation via ftp), all
with the same result. In other words, the configuration outlined in the /proc
files is only one of a number of similar ones where the installation fails.
Comment 6 Toralf 2002-01-11 08:22:34 EST
I tried connecting the harddisk to a different host, and got the same result
there. Looks like the installer has a problem with the particular hard drive I'm
using - it's a Seagate ST136403LW. I have installated successfully on at least
one other unit of the same model, though.

I have now given up using anaconda, and upgraded the system via "live" package
installation (exactly how bad is that, by the way?), and it seems to work quite
well after that. In other words, it is just the installer that has problems with
my hardware, not Linux itself. (Just as I thought.)

BTW, I'm used a custom front-end that will resolve dependencies etc. to do the
actual installation. I wrote it a while back because I couldn't find any
standard utilities that would do quite what I wanted...
Comment 7 Jeremy Katz 2002-03-01 01:09:01 EST
If you run parted on /dev/sda after creating the device node in the installer
environment, do you get any sort of errors?
Comment 8 Michael Fulbright 2002-04-10 14:20:30 EDT
Closing due to inactivity, please reopen if you contine to have problems.
Comment 9 Red Hat Bugzilla 2006-02-21 13:48:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.