Bug 57231 - /etc/ftp* config files should be noreplace
Summary: /etc/ftp* config files should be noreplace
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-07 15:33 UTC by Pekka Savola
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-13 13:42:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2001-12-07 15:33:42 UTC
As a result of the wu-ftpd update, my /etc/ftpaccess was moved to /etc/ftpaccess.rpmsave.

As a consequence, anonymous ftp access was opened for the world in the
configuration file (IIRC), and several other toggles (like where people can connect, where
PASV/PORT theft is allowed etc.) were "lost".

I think these files, or at least most of them, should be %noreplace.

Comment 1 Bernhard Rosenkraenzer 2001-12-13 13:35:30 UTC
They aren't noreplace because the /home/ftp -> /var/ftp change needed to get 
into every config file. Guess I'd better move that to a %post script, though.


Comment 2 Bernhard Rosenkraenzer 2001-12-13 13:42:09 UTC
Fixed in 2.6.2-1



Note You need to log in before you can comment on or make changes to this bug.