Bug 57232 - mod_python 2.7.6 segfaults in the cleanup handler
Summary: mod_python 2.7.6 segfaults in the cleanup handler
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mod_python (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-07 15:47 UTC by Mihai Ibanescu
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 17:50:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
COnfiguration file to be appended to httpd.conf (Include conf/crash.conf) (276 bytes, text/plain)
2001-12-07 15:53 UTC, Mihai Ibanescu
no flags Details
mod_python handlers (referred from crash.conf) (461 bytes, text/plain)
2001-12-07 15:54 UTC, Mihai Ibanescu
no flags Details
Patch that fixes the problem (1.71 KB, patch)
2002-03-06 17:50 UTC, Cristian Gafton
no flags Details | Diff

Description Mihai Ibanescu 2001-12-07 15:47:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
Somewhere between mod_python 2.7.3 and 2.7.6 they introduced something that
broke the cleanup handler. Red Hat 7.2 ships 2.7.6.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a mod_python handler
2. Watch it work OK without the cleanup handler defined, and segfaulting
with a defined cleanup handler
	

Actual Results:  Apache segfaults.
Since the cleanup handler is executed upon cleanup, the result is not
visible to the client, since the request is correctly served. But the httpd
process segfaults (tail -f /var/log/httpd/error.log)

Additional info:

IIRC every version after 2.7.4 has this problem.
Browsing the CVS rep doesn't show me anything strange added between 2.7.3
and 2.7.4.
I have to doublecheck if 2.7.4 is indeed the first version with the
problem. 2.7.6 which ships with Red Hat is definitely broken.

Comment 1 Mihai Ibanescu 2001-12-07 15:53:12 UTC
Created attachment 40047 [details]
COnfiguration file to be appended to httpd.conf (Include conf/crash.conf)

Comment 2 Mihai Ibanescu 2001-12-07 15:54:18 UTC
Created attachment 40048 [details]
mod_python handlers (referred from crash.conf)

Comment 3 Mihai Ibanescu 2001-12-07 15:56:04 UTC
Attached the configuration file and the mod_python handler.
To test this, point a browser to http://yourmachine.org/fisk

You should see something on the screen, but /var/log/httpd/error.log would show
httpd segfaulted

Comment 4 Cristian Gafton 2002-03-06 17:50:06 UTC
Created attachment 47622 [details]
Patch that fixes the problem

Comment 5 Cristian Gafton 2002-03-06 17:50:31 UTC
asigned to nalin

Comment 6 Nalin Dahyabhai 2002-04-22 16:20:58 UTC
Incorporated into 2.7.6-5 and later.  Please also make sure the modpython.org
folks get the patch.


Note You need to log in before you can comment on or make changes to this bug.