This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57236 - grub hangs on Tyan Thunder MOBO
grub hangs on Tyan Thunder MOBO
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-07 11:42 EST by David Thompson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-07 15:40:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
System configuration (3.10 KB, text/plain)
2001-12-07 11:47 EST, David Thompson
no flags Details

  None (edit)
Description David Thompson 2001-12-07 11:42:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.16-csl1smp i686)

Description of problem:
If I 'grub-install /dev/hda', the loader hangs after printing:
GRUB Loading stage 1.5.
If I 'grub-install /dev/fd0', the loader works, but prints
GRUB Loading stage 2...
twice before giving me the menu.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install red hat 7.2 with grub
2. reboot  :)
3.
	

Additional info:

This is a Tyan Thunder (2510) motherboard, 2xPIII/933MHz, 2 Gigs RAM
bios rev 1.05.
Comment 1 David Thompson 2001-12-07 11:47:12 EST
Created attachment 40049 [details]
System configuration
Comment 2 Jeremy Katz 2001-12-07 16:07:25 EST
Do you know if this board works if you are a) using LILO and b) have lba32
specified in /etc/lilo.conf?
Comment 3 David Thompson 2001-12-08 12:51:35 EST
Yes, it works fine with lilo in linear mode (that's what I'm doing now for a
workaround) and lba32 mode.
Comment 4 Jeremy Katz 2002-01-02 15:12:02 EST
Could you try the test package at http://people.redhat.com/~katzj/grub/.  If you
install the package and then run `/sbin/grub-install /dev/hda` (or wherever you
have grub installed other than /dev/hda) and let me know if that works better,
it would be great.
Comment 5 David Thompson 2002-01-07 15:40:13 EST
...and there was much rejoicing (yeah)

Yes, with the test rpm grub works great with this motherboard.  Modulo the
standard caveats, is there any reason I shouldn't use this in a production red
hat mirror (mirror.cs.wisc.edu)?

Dave
Comment 6 Jeremy Katz 2002-01-07 15:49:25 EST
Not that I know of...  boot loaders tend to be a "if it works once, it will keep
working" type of thing, and it's also pretty close to version 0.91 from all that
I gather.  Closing as rawhide since this will show up there soon.

Note You need to log in before you can comment on or make changes to this bug.