Bug 572365 - [abrt] crash in firefox-3.5.8-1.fc12: Process /usr/lib64/firefox-3.5.8/firefox was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in firefox-3.5.8-1.fc12: Process /usr/lib64/firefox-3.5.8/firefo...
Status: CLOSED DUPLICATE of bug 546155
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4a371655a44f125276548275cbc...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-11 00:40 UTC by Duncan Furniss
Modified: 2010-03-12 01:32 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-03-12 01:32:29 UTC


Attachments (Terms of Use)
File: backtrace (58.62 KB, text/plain)
2010-03-11 00:40 UTC, Duncan Furniss
no flags Details

Description Duncan Furniss 2010-03-11 00:40:41 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.5.8/firefox http://w3-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/WP101646
component: firefox
executable: /usr/lib64/firefox-3.5.8/firefox
kernel: 2.6.32.9-70.fc12.x86_64
package: firefox-3.5.8-1.fc12
rating: 4
reason: Process /usr/lib64/firefox-3.5.8/firefox was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. waited a while to print a page
2.
3.

Comment 1 Duncan Furniss 2010-03-11 00:40:43 UTC
Created attachment 399211 [details]
File: backtrace

Comment 2 Chris Campbell 2010-03-12 01:31:23 UTC
#5  0x00000034220ba2cd in __gnu_cxx::__verbose_terminate_handler ()
    at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
        terminating = true
        t = <value optimized out>
#6  0x00000034220b8456 in __cxxabiv1::__terminate (
    handler=<value optimized out>)
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:38
No locals.
#7  0x00000034220b8483 in std::terminate ()
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
No locals.
#8  0x00000034220b8daf in __cxxabiv1::__cxa_pure_virtual ()
    at ../../../../libstdc++-v3/libsupc++/pure.cc:50
No locals.
#9  0x0000003f87693c1e in nsCOMPtr_base::assign_from_qi (this=0x7fffd6f61c20, 
    qi=..., iid=...) at nsCOMPtr.cpp:96
        newRawPtr = 0x3f87693bc4
#10 0x0000003f8745e321 in nsCOMPtr (this=<value optimized out>, 
    aChromeEventHandler=0x7fffd6f61e10)
    at ../../dist/include/xpcom/nsCOMPtr.h:572
No locals.
#11 nsDocShell::GetChromeEventHandler (this=<value optimized out>, 
    aChromeEventHandler=0x7fffd6f61e10) at nsDocShell.cpp:1261
        target = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
#12 0x0000003f870037fe in DocumentViewerImpl::CreateStyleSet (
    this=<value optimized out>, aDocument=<value optimized out>, 
    aStyleSet=<value optimized out>) at nsDocumentViewer.cpp:2179
        uri = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        sheetService = <value optimized out>
        styleSet = 0x7f0745aae5c0
        shouldOverride = 0
        csssheet = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        quirkClone = {<nsCOMPtr_base> = {
            mRawPtr = 0x7f074497bfb0}, <No data fields>}
        dummy = {<nsCOMPtr_base> = {
            mRawPtr = 0x7f074497bfb0}, <No data fields>}
        sheet = 0x0
        ds = {<nsCOMPtr_base> = {mRawPtr = 0x7f0746c420f0}, <No data fields>}
        chromeHandler = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
#13 0x0000003f8733c26b in nsPrintEngine::ReflowPrintObject (
    this=0x7f0745d2db30, aPO=0x7f0746c78760) at nsPrintEngine.cpp:1948
        documentIsTopLevel = <value optimized out>
        frame = 0x0
        canCreateScrollbars = <value optimized out>
        rv = 0
        tbounds = {x = 0, y = 0, width = 495307113, height = 49}
        supps = {<nsCOMPtr_base> = {
            mRawPtr = 0x7fffd6f61f90}, <No data fields>}
        printBGColors = 0
        styleSet = <value optimized out>
        displayShell = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        selectionPS = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        parentView = <value optimized out>
        rootView = <value optimized out>
        selection = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
#14 0x0000003f8733c9a7 in nsPrintEngine::ReflowDocList (this=0x7f0745d2db30, 
    aPO=0x7f0746c78760, aSetPixelScale=0) at nsPrintEngine.cpp:1843
        rv = <value optimized out>
        cnt = <value optimized out>
#15 0x0000003f8733dfe2 in nsPrintEngine::SetupToPrintContent (
    this=0x7f0745d2db30) at nsPrintEngine.cpp:1651
        ppIsShrinkToFit = 0
        rv = <value optimized out>
        isPrintToFile = <value optimized out>
        docURLStr = <value optimized out>
        printRangeType = <value optimized out>
        doSetPixelScale = <value optimized out>
        startPage = <value optimized out>
        fileName = <value optimized out>
        docTitleStr = <value optimized out>
        endPage = <value optimized out>




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-03-12 01:32:29 UTC
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 546155 ***


Note You need to log in before you can comment on or make changes to this bug.