Bug 57237 - mod_auth_kerb reports "The document contains no data" with apache-1.3.22-1.7.1
mod_auth_kerb reports "The document contains no data" with apache-1.3.22-1.7.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-07 12:10 EST by Tim Brooks
Modified: 2007-03-26 23:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-31 09:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Brooks 2001-12-07 12:10:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
I successfully built an rpm with mod_auth_kerb support with the 
apache.spec file for apache-1.3.22-1.7.1.  However, directories 
configured for kerberos authentication via an .htaccess file do not 
prompt for a password.  Instead when a browser is pointed at the 
appropriate URL, a pop state that "The document contained not data.  Try 
again later, or contact the server's adminstrator".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Retrieve apache SRPM, edit apache.spec file with the following lines: 
Source8: 
http://stonecold.unity.ncsu.edu/software/mod_auth_kerb/downloads/mod_auth_
kerb-4.10.tar.gz
%build 
"CFLAGS="-DKRB5 -DKRB_DEF_REALM=\"KERBEROSREALM.COM\" -
DKRB5_SAVE_CREDENTIALS $RPM_OPT_FLAGS -fPIC -DEAPI_MM_CORE_PATH='\"%
{_localstatedir}/run/httpd.mm\"'" ;export CFLAGS
LIBS="-lpthread -L/usr/kerberos/lib -lkrb5 -lcrypto -lcom_err" ;export 
LIBS
INCLUDES=-I/usr/kerberos/include; export INCLUDES
./configure
--add-module=$RPM_SOURCE_DIR/mod_auth_kerb.c \
2. Edit httpd.conf with the following lines:
LoadModule kerb_auth_module   modules/mod_auth_kerb.so
AddModule mod_auth_kerb.c

<Directory /var/www/html/stuff>
AllowOverride AuthConfig Limit
AuthType KerberosV5
AuthName "Kerberos Secure Login"
KrbAuthRealm KERBEROSREALM.COM
KrbAnyInstance off
AuthGroupFile /home/htaccess/groups
require group stuff
</Directory>
3. Add .htaccess file to /var/www/html/stuff directory with the line:
require group stuff.

4. Restart webserver

5. Browse to URL www.domain.com/stuff
	

Actual Results:  Pop up appears that states: "The document contained not 
data.  Try again later, or contact the server's adminstrator".

Expected Results:  Should have an htaccess style pop up to login.

Additional info:

I have compiled mod_auth_kerb in for apache-1.3.14-3 and apache-1.3.19-
5.  It has worked until now.  This apache, however, has more changes than 
usual.
Comment 1 Tim Brooks 2001-12-10 11:26:03 EST
I have found that the mod_auth_kerb actually does work, but only with an .htaccess file that contains "require valid-user".  When I use "require user 
login" or "require group test", I get the "document contains no data".  I have also added this module as DSO on a different server with the same 
results.  The error log produces the following: 
[Mon Dec 10 09:31:39 2001] [notice] child pid 28080 exit signal Segmentation fault (11)
[Mon Dec 10 09:31:40 2001] [notice] child pid 28121 exit signal Segmentation fault (11)
Comment 2 Tim Brooks 2001-12-27 10:37:56 EST
I ended up trying this on a clean server, thereby bypassing any upgrade issues.  It worked just fine.
I then blew away the backup server I was trying to upgrade and did a fresh install to Red Hat 7.2.  I copied over the httpd.conf file 
from the previous upgrade and it failed again.  I then did a diff on the installation conf file and my reworked file.  A lot of stuff was showing 
up as being different when there was no difference.  I even went and checked for spaces.  Anyway, I rebuilt the file line by line, testing it 
with each addition.  I was never able to get to fail.  So, this ones a mystery.  Something in the upgraded conf file is killing it.

Tim Brooks
Comment 3 Joe Orton 2003-07-31 09:32:16 EDT
That was probably a bug in mod_auth_kerb rather than Apache itself.

Note You need to log in before you can comment on or make changes to this bug.