This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 572377 - kaffeine: Cannot create deinterlace plugin.
kaffeine: Cannot create deinterlace plugin.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kaffeine (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Janssen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-03-10 20:45 EST by Rex Dieter
Modified: 2010-04-27 21:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: kaffeine-1.0-0.5.pre3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 21:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kaffeine-1.0-pre3-deinterlace-optional.patch (3.51 KB, patch)
2010-04-15 15:20 EDT, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Rex Dieter 2010-03-10 20:45:54 EST
Always reports this when tvtime plugin is missing (part of -freeworld codecs atm).

Not sure of tv decoding is even practical with any only free codecs, may have to patch out the warning/error.

Tested with
kaffeine-1.0-0.4.pre3.fc13
and
xine-lib-1.1.18.1-1.fc13
Comment 1 Fedora Admin XMLRPC Client 2010-04-08 12:49:59 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Kevin Kofler 2010-04-15 14:41:27 EDT
Kaffeine probably needs a change similar to this old (upstreamed a long time ago) Phonon patch:
http://cvs.fedoraproject.org/viewvc/rpms/kdebase-runtime/devel/kdebase-runtime-4.0.3-deinterlace-crash.patch?hideattic=0&revision=1.1&view=markup
Comment 3 Kevin Kofler 2010-04-15 14:44:37 EDT
Here's the upstream change which introduced the deinterlacing requirement, I can see to make this optional:
http://websvn.kde.org/?view=revision&revision=1076114
Comment 4 Kevin Kofler 2010-04-15 15:20:12 EDT
Created attachment 406895 [details]
kaffeine-1.0-pre3-deinterlace-optional.patch

This quick&dirty patch should fix this. The quick&dirty part is that it doesn't gray out the option in the UI if it's not available, it just silently ignores it. The problem is that the UI is not communicating with xine-lib directly, but only through IPC (I don't understand why they do this, Phonon-Xine uses xine-lib in process just fine), which makes it hard to reflect this stuff in the UI.
Comment 5 Rex Dieter 2010-04-15 15:37:32 EDT
otoh, I suppose if we could identify exactly which -freeworld bits are needed here, I could recheck it's legal/patent status to try getting it into fedora's xine-lib.
Comment 6 Fedora Update System 2010-04-27 09:10:31 EDT
kaffeine-1.0-0.5.pre3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kaffeine-1.0-0.5.pre3.fc13
Comment 7 Fedora Update System 2010-04-27 09:11:27 EDT
kaffeine-1.0-0.5.pre3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kaffeine-1.0-0.5.pre3.fc12
Comment 8 Fedora Update System 2010-04-27 21:12:05 EDT
kaffeine-1.0-0.5.pre3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-04-27 21:17:33 EDT
kaffeine-1.0-0.5.pre3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.