Bug 572503 - Texmaker Editor stops accepting UTF-8 characters
Summary: Texmaker Editor stops accepting UTF-8 characters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texmaker
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-11 12:06 UTC by Luis Cruz
Modified: 2010-07-30 08:45 UTC (History)
2 users (show)

Fixed In Version: texmaker-1.9.9-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-30 08:45:02 UTC


Attachments (Terms of Use)

Description Luis Cruz 2010-03-11 12:06:54 UTC
Description of problem:

After using Texmaker for a variable period of time, the editor suddenly stops accepting UTF-8 characters like "ç", "ã" or "õ", which are needed for writing documents in languages other than english.


Version-Release number of selected component (if applicable): Texmaker 1.9.9


How reproducible: Always


Steps to Reproduce:
1. Use the Texmaker text editor for a variable period of time. Sometimes the problem simply disappears by itself and then comes back again after some time.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fabien Archambault 2010-07-21 09:45:35 UTC
Hello,

I have exactly the same behavior and I asked upstream if it exists a solution for this issue. The problem was also reproducible upstream but they cannot figure out where was the problem. The only solution foudn was to update to qt 4.6.3 then the problem disapeared.

I got the srpm for texmaker and recompiled it with the latest version of qt available in Fedora. Then I created a rpm of texmaker and then used texmaker for more than an hour without being able to reproduce it (before I would have reproduced it in that amount of time).

If it was possible to recompile the package in order to correct this problem.

Thanks

Comment 2 Fedora Update System 2010-07-21 16:43:47 UTC
texmaker-1.9.9-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/texmaker-1.9.9-2.fc12

Comment 3 Fabien Archambault 2010-07-22 08:08:11 UTC
Hello,

is it possible to get it for Fedora 13. I did not check that the original bug report was against Fedora 12

Comment 4 Fedora Update System 2010-07-23 02:24:18 UTC
texmaker-1.9.9-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update texmaker'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/texmaker-1.9.9-2.fc12

Comment 5 Fedora Update System 2010-07-30 08:44:58 UTC
texmaker-1.9.9-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.