This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 572534 - [abrt] crash in authconfig-gtk-6.0.0-2.fc12: authinfo.py:993:backup:OSError: [Errno 13] Permission denied: '/var/lib/authconfig/last'
[abrt] crash in authconfig-gtk-6.0.0-2.fc12: authinfo.py:993:backup:OSError: ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
abrt_hash:b598b941
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-11 08:45 EST by JYundt
Modified: 2010-09-15 07:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: authconfig-6.1.2-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 07:42:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (855 bytes, text/plain)
2010-03-11 08:45 EST, JYundt
no flags Details
contents of /var/lib/authconfig/last (2.56 KB, application/x-bzip)
2010-03-11 09:08 EST, JYundt
no flags Details

  None (edit)
Description JYundt 2010-03-11 08:45:31 EST
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/share/authconfig/authconfig-gtk.py
component: authconfig
executable: /usr/share/authconfig/authconfig-gtk.py
kernel: 2.6.32.9-70.fc12.i686
package: authconfig-gtk-6.0.0-2.fc12
reason: authinfo.py:993:backup:OSError: [Errno 13] Permission denied: '/var/lib/authconfig/last'
release: Fedora release 12 (Constantine)

backtrace
-----
authinfo.py:993:backup:OSError: [Errno 13] Permission denied: '/var/lib/authconfig/last'

Traceback (most recent call last):
  File "/usr/share/authconfig/authconfig-gtk.py", line 781, in <module>
    module.apply(xml)
  File "/usr/share/authconfig/authconfig-gtk.py", line 725, in apply
    self.info.writeChanged(self.pristineinfo)
  File "/usr/share/authconfig/authinfo.py", line 3324, in writeChanged
    ret = ret and group.saveFunction()
  File "/usr/share/authconfig/authinfo.py", line 2869, in writeNSS
    all_configs[CFG_NSSWITCH].backup(self.backupDir)
  File "/usr/share/authconfig/authinfo.py", line 993, in backup
    os.mkdir(destdir)
OSError: [Errno 13] Permission denied: '/var/lib/authconfig/last'

Local variables in innermost frame:
rv: True
destdir: '/var/lib/authconfig/last'
err: 0
self: <authinfo.FileBackup instance at 0x8a4352c>
Comment 1 JYundt 2010-03-11 08:45:33 EST
Created attachment 399339 [details]
File: backtrace
Comment 2 Tomas Mraz 2010-03-11 08:59:07 EST
How did you run the authconfig-gtk command? Is there the /var/lib/authconfig/last directory?
Comment 3 JYundt 2010-03-11 09:08:59 EST
Created attachment 399351 [details]
contents of /var/lib/authconfig/last
Comment 4 JYundt 2010-03-11 09:10:12 EST
I tried authconfig first in gnome "System -> Administration -> Authentication" and then via command line when it kept crashing.  I uploaded the contents of /var/lib/authconfig/last.  I was trying to configure SSSD (very unsuccessfully) to authenticate against AD.
Comment 5 Tomas Mraz 2010-03-11 09:30:09 EST
When you run it from System->Administration->Authentication - I suppose it did not spawn ABRT to report the bug?

And when you run it from command line - was that regular user command line or from the root account through su -?

Can you please try running it from su -? Because directly running it from regular user would mean that similar errors will occur, you obviously have to run it as root so it is able to write to the system configuration files.
Comment 6 JYundt 2010-03-11 09:52:07 EST
You are correct, when I used the gui, ABRT didn't catch it.  

And yes, I was a non-super user when I ran it via the commandline.  I figured it wouldn't let me write to the config files, I didn't expect it to crash.

Running it as root (via command line works).  However, I have since rebooted my machine (due to a yum update) and the gui works again.  Sorry if this hurts your debugging efforts...
Comment 7 Tomas Mraz 2010-03-11 10:08:14 EST
Unfortunately the crash when run from GUI was probably unrelated to this crash reported by ABRT. Though I will fix this so this exception is catched.
Comment 8 JYundt 2010-03-11 10:09:07 EST
Ok, let me know if you need any additional information/logs.
Comment 9 David L. Fretz 2010-08-09 12:35:46 EDT
Package: authconfig-gtk-6.0.0-2.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1.open system-config-authentication in GNOME
2.change nothing
3.click on apply


Comment
-----
The system is setup to do LDAP authentication.  However, changing nothing seems to cause this crash.

Note You need to log in before you can comment on or make changes to this bug.