Bug 57265 - Minor patch to .spec to build with latest auto* tools
Summary: Minor patch to .spec to build with latest auto* tools
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnorpm   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-08 01:51 UTC by Bill Crawford
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-13 16:56:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quick fix to get gnorpm to build with latest autoconf/automake. (323 bytes, patch)
2001-12-08 01:52 UTC, Bill Crawford
no flags Details | Diff

Description Bill Crawford 2001-12-08 01:51:38 UTC
Patch follows.  It's probably not the "right" fix but it builds.  The
new-autoconf-generated ./configure needs some files adding, which doesn't
happen right if automake /autoconf are run before aclocal, for reasons I'm
not really interested in right now :o)

Comment 1 Bill Crawford 2001-12-08 01:52:42 UTC
Created attachment 40068 [details]
Quick fix to get gnorpm to build with latest autoconf/automake.

Comment 2 Havoc Pennington 2001-12-08 02:28:55 UTC
Right now it looks like we're going to give up on automake 1.5 and revert to
1.4, because 100+ packages are failing similarly. :-/ Though in this case the
patch was a simple "aclocal" which is encouraging.

I'll keep the bug open until we figure out what to do.

Comment 3 Bill Crawford 2001-12-08 02:42:52 UTC
Reverting is quite tempting, I spent a week or two downgrading so I could build
control-center and a couple of other things.  I'm not sure whether I'd rather
have the pain now or later (and you guys have to make that call too).

FWIW I would expect most packages to get fixed upstream (slowly) and anything
that's built from a dist source rather than a CVS snapshot should (hopefully)
not be dependent on what are supposed to be maintainer-only tools, anyway.

You may even be able to fix them all by twiddling the %configure macro in
/usr/lib/rpm/macros (I had a stab at this, but I'm not used to hacking around in
there and all the %_percentSignUnderscoreSomething macros were confusing me :o)


Comment 4 Bill Crawford 2001-12-08 02:46:24 UTC
Oh, and thanks for "GNOME Hide" btw, the newer stuff looks "prettier" and a lot
of apps "feel" a bit faster.  Some of that might be down to the 2.4.16 kernel,
but ...

Comment 5 Havoc Pennington 2002-02-26 20:54:04 UTC
automake mess approximately cleaned up now.


Note You need to log in before you can comment on or make changes to this bug.