Bug 572662 - 3proxy starts when not told to
Summary: 3proxy starts when not told to
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: 3proxy
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-11 19:30 UTC by Pat Gunn
Modified: 2010-04-09 04:25 UTC (History)
2 users (show)

Fixed In Version: 3proxy-0.6.1-8.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-15 19:28:25 UTC
Type: ---


Attachments (Terms of Use)

Description Pat Gunn 2010-03-11 19:30:26 UTC
Description of problem:3proxy is disabled, according to chkconfig, but it starts as a service anyway (getting in the way of running local Apache). I strongly suspect this is because of its NetworkManager script:

/etc/NetworkManager/dispatcher.d/40-3proxy

being trigger-happy about starting it.


Version-Release number of selected component (if applicable): 0.6.7.fc13


How reproducible: 100%


Steps to Reproduce:
1. chkconfig to ensure 3proxy is disabled
2. start system
  
Actual results:
3proxy runs, anything else that might've wanted port 80 (such as apache) does not.

Expected results:
3proxy doesn't run unless enabled

Additional info:

Comment 1 Pavel Alexeev 2010-03-11 20:07:03 UTC
Thank you for the report.

Is it reproducable without system reboot?

Comment 2 Pat Gunn 2010-03-11 20:13:02 UTC
It doesn't come back on its own - I'm guessing either NetworkManager starts it when a network connection comes up (which I don't tend to do a lot outside of system boots) or init/upstart does it through some code path I haven't spotted yet.

I'll do more testing - if nobody has an "aha!" moment, I'll fill in more details.

Comment 3 Pat Gunn 2010-03-11 23:55:09 UTC
Removing that script fixed the problem. So, either that script needs to be made much more clever (seeing if 3proxy should be running in the current runlevel) or it should be removed.

Comment 4 Pavel Alexeev 2010-03-12 07:34:56 UTC
Try replace
/sbin/service 3proxy restart || :
by
/sbin/service 3proxy condrestart || :
in it.

Comment 5 Kevin Fenzi 2010-03-12 18:54:31 UTC
I just had someone run into a problem with httpd due to this. 3proxy started up and kept ports in use and httpd couldn't start. :( 

A condrestart might be an ok solution...

Comment 6 Pavel Alexeev 2010-03-14 19:10:09 UTC
Pat Gunn, please can you confirm what it resolve problem? I think yes.
If so, I'll immediately post update.

Comment 7 Pat Gunn 2010-03-14 19:43:03 UTC
That replacement fixed it.

Comment 8 Pavel Alexeev 2010-03-14 21:53:58 UTC
Ok, thanks. Update follow.

Comment 9 Fedora Update System 2010-03-15 11:55:20 UTC
3proxy-0.6.1-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/3proxy-0.6.1-8.fc13

Comment 10 Fedora Update System 2010-03-15 15:00:04 UTC
3proxy-0.6.1-8.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/3proxy-0.6.1-8.fc12

Comment 11 Fedora Update System 2010-03-15 15:12:53 UTC
3proxy-0.6.1-8.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/3proxy-0.6.1-8.fc11

Comment 12 Fedora Update System 2010-03-15 15:24:37 UTC
3proxy-0.6.1-8.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/3proxy-0.6.1-8.el5

Comment 13 Fedora Update System 2010-04-02 02:42:17 UTC
3proxy-0.6.1-8.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-04-03 04:36:19 UTC
3proxy-0.6.1-8.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-04-03 04:37:03 UTC
3proxy-0.6.1-8.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-04-09 04:25:26 UTC
3proxy-0.6.1-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.