Bug 572744 - RFE: provide easy way to get the IP address of (the interfaces of) a guest
RFE: provide easy way to get the IP address of (the interfaces of) a guest
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-11 17:15 EST by Dave Malcolm
Modified: 2010-07-12 13:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 13:15:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-03-11 17:15:27 EST
Description of problem:
I typically want to ssh into a host from virt-manager, but I can't see an easy way to get at the IP address of a machine (I tend to go in via the graphical console, run ifconfig, then scrape the IP address from there; am I missing something here?  the graphical interface is overkill if I'm connecting via VPN on a slow connection).

Currently the information page about a network interface has an editable field for the MAC address.

Would it be possible to add an IP address field below it?  It would be non-editable, but should be copy-and-pasteable.  (via e.g. Reverse ARP? DHCP?)

If the guest has a single interface, could the IP address also be added to the overview page?

(further ideas: a "Connect via SSH" button that launches a gnome-terminal with a pre-canned ssh to the IP address, either as root or as the local user running virt-manager?)

Version-Release number of selected component (if applicable):
virt-manager-0.8.0-7.fc12.noarch
Comment 1 Cole Robinson 2010-05-10 16:15:49 EDT
Unfortunately there isn't an easy way to get a guests IP address from outside the VM, it's one of those things that really requires an agent in the VM to communicate with management over vmchannel or similar.

Since presumably this info would eventually come from some libvirt API, reassigning there.
Comment 2 Daniel Berrange 2010-07-12 13:15:38 EDT
There's no way for libvirt to provide this information really.

Note You need to log in before you can comment on or make changes to this bug.