This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 572772 - Intel graphics driver leaves artefacts and doesn't refresh with F-13 on Dell Inspiron 6400
Intel graphics driver leaves artefacts and doesn't refresh with F-13 on Dell ...
Status: CLOSED DUPLICATE of bug 570517
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
card_945GM
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-11 19:02 EST by Bojan Smojver
Modified: 2010-05-18 09:10 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-15 15:21:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X log (this particular one resulted in a crash upon resume, but still show hw etc.) (372.56 KB, text/plain)
2010-03-12 17:54 EST, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2010-03-11 19:02:57 EST
Description of problem:
With compiz enabled, Intel driver is leaving artefacts on the screen. Also, windows do not get refreshed until they get scrolled or similar. This is with F-13 alpha with updates up until 11 Mar 2010.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.10.0-4.fc13

How reproducible:
Always.

Steps to Reproduce:
1. Boot F-13 alpha.
2. Switch to compiz.
3. Open Gnome terminal. Observe artefacts when typing in commands. Oopen FF. Observe that new pages are occasionally not refreshed when loaded, until some scrolling is applied.
  
Actual results:
Artefacts on screen. Problems with refresh.

Expected results:
This works fine in F-12 without KMS (I'm not using KMS with F-12 due to hibernate/thaw problems). With F-13, no KMS is not an option, so I cannot see if that would help.

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=537494#c31
Comment 1 Adam Williamson 2010-03-12 16:43:03 EST
Can we get an Xorg.0.log? Thanks. Can you confirm it's OK with compiz disabled?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Bojan Smojver 2010-03-12 17:54:30 EST
Created attachment 399776 [details]
X log (this particular one resulted in a crash upon resume, but still show hw etc.)
Comment 3 Bojan Smojver 2010-03-12 17:56:31 EST
I'll check without compiz. When I initially installed, I haven't noticed any artefacts, but I didn't check in detail.
Comment 4 Adam Williamson 2010-03-12 18:06:07 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Matěj Cepl 2010-03-15 15:21:59 EDT

*** This bug has been marked as a duplicate of bug 570517 ***
Comment 6 Evgeny F 2010-04-03 10:42:48 EDT
This does not seem as bug 570517 at all. There is no mention of corruption (or screen freeze) in Xorg.0.log, however the symptoms are there. (no screen refresh)
Comment 7 trevik 2010-04-06 17:09:37 EDT
The bug probably is not a duplicate of bug 570517 - the behaviour is different -  screen is simply corrupted because of lack of proper refresh. Hibernation / resume results in crash (I think it is GPU - driver - KMS combo regression).
Without compiz (with metacity) the screen for 2d apps seems to refresh fine.
Comment 8 Matěj Cepl 2010-04-07 06:37:20 EDT
(In reply to comment #7)
> The bug probably is not a duplicate of bug 570517 - the behaviour is different
> -  screen is simply corrupted because of lack of proper refresh. Hibernation /
> resume results in crash (I think it is GPU - driver - KMS combo regression).
> Without compiz (with metacity) the screen for 2d apps seems to refresh fine.    

The error message is the same, and both happen when switching to 3D mode (either through Desktop Effects, or by using compiz).

Given the amount of open bugs we have against this component and given this bug doesn't seem to bring anything new to the table, so I am keeping it closed. I am very open to be persuaded otherwise.
Comment 9 Bojan Smojver 2010-04-07 08:17:26 EDT
Don't particularly care which bugs stay open or closed. One thing is for sure - the state of the Intel driver is pretty sad.
Comment 10 Matěj Cepl 2010-04-07 10:51:33 EDT
(In reply to comment #9)
> Don't particularly care which bugs stay open or closed. One thing is for sure -
> the state of the Intel driver is pretty sad.    

Unfortunately, I have to agree with you.
Comment 11 Nikolay Vladimirov 2010-04-14 09:15:56 EDT
Just note that I'm getting the same behavior on intel 4500MHD on thinkpad r500. So it's a somewhat common bug. With desktop effects disabled everything works fine.
Comment 12 Rodrigo Ayala 2010-04-14 21:51:33 EDT
I have the same problem... my videocard is an Intel 945GM, and I'm running Fedora 13 Beta, with all the updates... it's seems that is a problem of refresh...
This doesn't happens in Fedora 12...
Comment 13 Adam Drew 2010-05-14 15:14:21 EDT
Having the same issues on a 4500MHD. Objects on screen don't update correctly. Works fine in Ubuntu 10.04
Comment 14 Nikolay Vladimirov 2010-05-14 19:04:29 EDT
Actually, I can no longer reproduce this on 4500MHD. I can't say for how long it was fixed since I haven't tried compiz in almost a month. 
I'm using latest F-13 updates-testing as of today( May 14, xorg-x11-drv-intel-2.11.0-4.fc13.x86_64 ).
Comment 15 trevik 2010-05-18 09:10:58 EDT
It seems that the bug is away with my configuration. F-13 is updated, driver 
xorg-x11-drv-intel-2.11.0-4.fc13.i686
auch bug 570517 disappeared (suspend resume works as expected).
HW:
    42.354] (--) PCI:*(0:0:2:0) 8086:27ae:1462:0110 Intel Corporation Mobile 945GME Express Integrated Graphics Controller rev 3, Mem @ 0xdfe80000/524288, 0xc0000000/268435456, 0xdff00000/262144, I/O @ 0x0000d0f0/8, BIOS @ 0x????????/131072
[    42.354] (--) PCI: (0:0:2:1) 8086:27a6:1462:0110 Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller rev 3, Mem @ 0xdfe00000/524288, BIOS @ 0x????????/65536

S/W:
X.Org X Server 1.8.0
Release Date: 2010-04-02
[    41.966] X Protocol Version 11, Revision 0
[    41.967] Build Operating System: x86-01 2.6.18-164.15.1.el5 
[    41.967] Current Operating System: Linux trevnote-lg 2.6.33.3-85.fc13.i686 #1 SMP Thu May 6 18:44:12 UTC 2010 i686
[    41.968] Kernel command line: ro root=/dev/sda4 resume=/dev/sda2 enforcing=0 intel_iommu=off LANG=en_US.UTF-8 KEYTABLE=us
[    41.968] Build Date: 02 May 2010  02:56:54PM
[    41.968] Build ID: xorg-x11-server 1.8.0-12.fc13

Note You need to log in before you can comment on or make changes to this bug.