Bug 572794 - service argument completion is broken
Summary: service argument completion is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bash-completion
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 546379 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-12 01:59 UTC by Todd Zullinger
Modified: 2010-06-16 17:01 UTC (History)
3 users (show)

Fixed In Version: bash-completion-1.1-6.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-02 02:42:34 UTC
Type: ---


Attachments (Terms of Use)
Apply upstream post 1.1 service argument fix. (2.48 KB, patch)
2010-03-12 01:59 UTC, Todd Zullinger
no flags Details | Diff

Description Todd Zullinger 2010-03-12 01:59:53 UTC
Created attachment 399519 [details]
Apply upstream post 1.1 service argument fix.

I noticed when some EL-5 systems updated recently that the service argument completion was broken.  I had fixed this locally a while back on many of my daily use boxes and saw it was fixed upstream so I didn't expect to find it broken in the latest EPEL push.  Apologies for not catching this while it was in epel-testing.  I think this one is worthy of a patch release, unless a new upstream release is imminent, as it is a decent regression from the previous release.  Attached is a patch against the devel branch to apply your upstream fix for the bug.

Comment 1 Ville Skyttä 2010-03-12 19:23:59 UTC
Agreed, I had a nagging feeling that there was something important I should have already backported from upstream git but it kept eluding me (and I personally mostly use bleeding edge upstream code so I didn't notice myself), thanks.

A new upstream release isn't that far away but it is possible that it'll come with some incompatibilities that wouldn't be suitable to do in EPEL.  Anyway, will push this to all active distro versions.

Comment 2 Fedora Update System 2010-03-12 19:37:27 UTC
bash-completion-1.1-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bash-completion-1.1-6.fc13

Comment 3 Fedora Update System 2010-03-12 19:39:05 UTC
bash-completion-1.1-6.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/bash-completion-1.1-6.el5

Comment 4 Fedora Update System 2010-03-12 19:41:05 UTC
bash-completion-1.1-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/bash-completion-1.1-6.fc12

Comment 5 Fedora Update System 2010-03-12 19:41:49 UTC
bash-completion-1.1-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/bash-completion-1.1-6.fc11

Comment 6 Todd Zullinger 2010-03-12 21:37:41 UTC
(In reply to comment #1)
> Agreed, I had a nagging feeling that there was something important I should
> have already backported from upstream git but it kept eluding me (and I
> personally mostly use bleeding edge upstream code so I didn't notice myself),
> thanks.

Oh, I hate that feeling.

> A new upstream release isn't that far away but it is possible that it'll come
> with some incompatibilities that wouldn't be suitable to do in EPEL.  Anyway,
> will push this to all active distro versions.    

Many thanks Ville.

Comment 7 Fedora Update System 2010-03-16 19:35:40 UTC
bash-completion-1.1-6.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bash-completion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bash-completion-1.1-6.el5

Comment 8 Fedora Update System 2010-03-18 03:28:13 UTC
bash-completion-1.1-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-03-20 03:27:42 UTC
bash-completion-1.1-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-04-02 02:42:29 UTC
bash-completion-1.1-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-04-03 04:35:05 UTC
bash-completion-1.1-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Ville Skyttä 2010-06-16 17:01:16 UTC
*** Bug 546379 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.