Bug 572799 - Install never appears on Lenovo x201
Summary: Install never appears on Lenovo x201
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-12 02:39 UTC by Ulrich Drepper
Modified: 2010-08-03 01:11 UTC (History)
18 users (show)

Fixed In Version: kernel-2.6.33.6-147.2.4.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-03 01:11:27 UTC


Attachments (Terms of Use)
syslog after failed wlan lookup (60.09 KB, text/plain)
2010-04-26 20:27 UTC, Ulrich Drepper
no flags Details
anaconda.log files (992 bytes, text/plain)
2010-04-26 20:28 UTC, Ulrich Drepper
no flags Details
hacked up patch which makes the display work on Thinkpad x201 (3.34 KB, text/plain)
2010-06-22 01:17 UTC, Matt Wringe
no flags Details

Description Ulrich Drepper 2010-03-12 02:39:44 UTC
Description of problem:
Trying to install F13alpha or F12 fails completely early on.  I PXE boot the machine (no CDROM drive).  Everything is pulled in nicely, /sbin/loader is started.  After that, I think, a short message about discovering hardware is shown.

I'm not so sure about this because immediately the screen is blanked.  This is where the system then seems to hang.  Nothing at all happens.  I left it for more than 30 mins on one occasion.

Version-Release number of selected component (if applicable):
F13alpha netinstall ISO
F12 full DVD ISO

How reproducible:
always

Steps to Reproduce:
1.PXE boot x201
2.
3.
  
Actual results:
blank screen after loader is started

Expected results:
Installer appears

Additional info:
One difference: in F12 the backlight of the TFT is on. In F13aloha it is off.  In case this rings a bell.

Comment 2 Chris Lumens 2010-03-12 15:51:40 UTC
> Trying to install F13alpha or F12 fails completely early on.  I PXE boot the
> machine (no CDROM drive).  Everything is pulled in nicely, /sbin/loader is
> started.  After that, I think, a short message about discovering hardware is
> shown.

There are a couple messages that could be the last thing you're seeing here.  Fairly early on, there are these two:

hardware.c:    fprintf(stderr, "detecting hardware...\n");
hardware.c:    fprintf(stderr, "waiting for hardware to initialize...\n");

Then later once the graphical part of anaconda starts, there's this guy:

        w = self.anaconda.intf.waitWindow(_("Finding Devices"),
                                          _("Finding storage devices"))

Do you happen to know which you're seeing, or perhaps you can reproduce this and attach the exact message.

> I'm not so sure about this because immediately the screen is blanked.  This is
> where the system then seems to hang.  Nothing at all happens.  I left it for
> more than 30 mins on one occasion.

Yeah there's a lot of possible causes for this, unfortunately, and none of them are going to be fun to track down.

Comment 3 Ulrich Drepper 2010-03-12 16:04:46 UTC
(In reply to comment #2)
> hardware.c:    fprintf(stderr, "detecting hardware...\n");
> hardware.c:    fprintf(stderr, "waiting for hardware to initialize...\n");

Both of these messages appear and then the screen is blanked.  Immediately after the second message.

In case it matters, this is an i7 CPU, 4GB RAM, SSD.

Comment 4 Hans de Goede 2010-03-15 11:53:03 UTC
This is most likely an Xorg / kms bug. Can you try to start anaconda with nomodeset on the kernel cmdline ?

If that gets you in to loader it is a kms bug. If it then crashes when trying to enter stage2, we also have a plain ums bug. In either case we will need to know
what kind of graphics card this machine is using, so we can re-assign it to the proper component.

As for RHEL-6 impact, you may want to file a separate bug against RHEL-6 for this.

Comment 7 Ulrich Drepper 2010-03-26 22:23:57 UTC
Using nomodeset I actually can see the installer.  I still cannot provide the lspci information because I don't get much further.

After the question re v4/v6 network the installer insists on using the wlan interface.  Even after I use the rfkill switch.  The machine booted via the ethernet port.

I cannot say what the exact model number for the ethernet chip is.  It's definitely some e1000 variant.  Is there any other reason but an unknown ethernet port for the installer to not use it?

The wlan use doesn't go anywhere either.  NetworkManager is started but always fails.  On The log console I see

  NOTICE NetworkManager:   ifcfg-rh:   error: Missing SSID

The network doesn't have a hidden SSID.

Is there a way to completely disable the wlan from the kernel command line?  Any other suggestions?

I've moved the bug back to anaconda.  Once I know the graphic chipset details I'll open a bug for the X server.

Comment 8 Ulrich Drepper 2010-03-30 14:09:49 UTC
Any comments?  What testing can I do?  Any alternate boot images which provide more debugging etc?

Comment 9 Jethro Carr 2010-04-09 14:29:48 UTC
I'm experiencing the same problems on a Lenovo X201i laptop with both F12 and F13 Alpha installers.

So far I have tracked it down to an issue with kernel mode setting - if it's enabled, the screen just goes blank and the laptop never goes anywhere. If you disable KMS, installation will proceed.

From my understanding, the GPU on these laptops is Intel HD Graphics (also called GMA HD) which is integrated with the core i5 CPU.

According to http://www.thinkwiki.org/wiki/Intel_HD_Graphics, kernel 2.6.33 and Intel Xorg driver 2.10 or newer is recommended, which is not met by F12 but is by F13 Alpha.


My symptoms:

* Standard F12 kernel and xorg intel drivers will cause a complete system crash.

* Standard F13 kernel and xorg intel drivers will no longer cause a complete system crash, however the screen goes completely blank and the laptop is only reachable via the network.


Probably best to file a KMS/Xorg bug on this rather than an Anaconda bug?

Comment 10 Ulrich Drepper 2010-04-09 14:52:20 UTC
(In reply to comment #9)
> * Standard F13 kernel and xorg intel drivers will no longer cause a complete
> system crash, however the screen goes completely blank and the laptop is only
> reachable via the network.

You got the network to work?  This doesn't work for me.  What install media did you use?

Comment 11 Jethro Carr 2010-04-09 15:23:10 UTC
(In reply to comment #10)
> You got the network to work?  This doesn't work for me.  What install media did
> you use?    

Yup, network worked fine for me with the ethernet e1000 driver.

However the wifi is more interesting - The X201i series ship with a couple different possible wifi cards, depending on the exact model and options at the time of order.

I ordered mine with the "ThinkPad b/g/n Wi-Fi wireless LAN Mini-PCIe" but there is also a "Intel WiFi Link 1000" option on some of the models.

The card I got turned out to be a rtl8192se which isn't supported in Fedora 12, so it would never obstruct the installer (the card does have linux drivers tho, see http://tinyurl.com/yc4zurr for more info about setting it up).

I'm guessing that the card in your laptop may be a different chipset which Fedora is recognising but for whatever reason is failing to work correctly with, whereas for me, Fedora wasn't even aware of the wifi.


I did my install using the boot image on a USB drive and then installing via HTTP.

Comment 12 Ulrich Drepper 2010-04-17 15:40:30 UTC
Ajax analyzed the video problem.  More recent kernels or backports for the Intel driver will fix it.  I see the video stuff working with a RHEL6 boot media which has the backport.

But my machine's ethernet chips seems not to be recognized by the installer.  I have a live image on a USB stick and it will happily use the chip.  But the installer complaints that it cannot find the driver and refuses to continue the installation (media comes over NFS).

What info do the anaconda guys need to track this down?

Comment 13 Jethro Carr 2010-04-22 00:06:20 UTC
Confirmed for myself as well, after building the RHEL 6 beta kernel 2.6.32-19 on Fedora 13 beta the problem with video was resolved.

However the problem still remains with the Fedora 13 Beta kernel, tested with 2.6.33-2-57

Comment 14 Chris Lumens 2010-04-26 14:08:18 UTC
> Ajax analyzed the video problem.  More recent kernels or backports for the
> Intel driver will fix it.  I see the video stuff working with a RHEL6 boot
> media which has the backport.

Then we should probably retitle this bug so it's obvious what issue it is now tracking.

> But my machine's ethernet chips seems not to be recognized by the installer.  I
> have a live image on a USB stick and it will happily use the chip.  But the
> installer complaints that it cannot find the driver and refuses to continue the
> installation (media comes over NFS).
> 
> What info do the anaconda guys need to track this down?    

The contents of tty3, 4, and 5 would be helpful.  Screenshots are acceptable.  I feel like this is likely to be a driver bug, though, as anaconda has very little to do with module loading anymore.  We basically just trust that the module knows which hardware it supports.

Comment 15 Ulrich Drepper 2010-04-26 14:39:33 UTC
(In reply to comment #14)
> The contents of tty3, 4, and 5 would be helpful.  Screenshots are acceptable. 
> I feel like this is likely to be a driver bug, though, as anaconda has very
> little to do with module loading anymore.  We basically just trust that the
> module knows which hardware it supports.    

This is with the F13beta over PXE.  With nomodeset so that I see anything.

The installer fails when it cannot use the wlan device.  Although of course an ethernet cable is plugged in so that PXE works.

tty3 shows info re floppy and CDROM (neither exists) and then the network status.  The most important line

INFO loader: only have one network device: wlan0

This is wrong, there is an ethernet port.

On tty4 all the non-wlan messages are scrolled off.  The wlan is encrypted so I don't expect that to work (should it)?  The firmware module is present (iwlwifi-6000).

tty5 is empty.


I assume the important thing here is the message of the ethernet module (should be a normal 1G Intel card).  How can I see that?  I now the card is supported.  When using the lifecd I can use the ethernet connection.

Comment 16 Chris Lumens 2010-04-26 17:40:49 UTC
If you hit ^Z when you get to this error dialog, do you get dropped to a shell?  If so, you are in an extremely limited environment where you should have enough stuff to copy /tmp/syslog and /tmp/anaconda.log to a USB key or similar.  Note that you have busybox to provide a lot of the missing utilities.

Comment 17 Ulrich Drepper 2010-04-26 18:26:55 UTC
(In reply to comment #16)
> If you hit ^Z when you get to this error dialog, do you get dropped to a shell?
>  If so, you are in an extremely limited environment where you should have
> enough stuff to copy /tmp/syslog and /tmp/anaconda.log to a USB key or similar.
>  Note that you have busybox to provide a lot of the missing utilities.    

I did that.  I then saw that the e1000e module is loaded.  But the interface isn't configured.  In fact, it doesn't even appear in the ifconfig output.  After removing the module and adding it back NetworkManger correctly configured it.  I.e., dhclient ran and the interface got the correct IP address.

Unfortunately fg doesn't work after ^Z so I cannot continue.

What do you want me to look at next?

Comment 18 Chris Lumens 2010-04-26 18:42:04 UTC
exit will return you to anaconda.

I'd like you to attach /tmp/syslog and /tmp/anaconda.log to this bug report if you can.

Comment 19 Ulrich Drepper 2010-04-26 20:26:49 UTC
(In reply to comment #18)
> exit will return you to anaconda.
> 
> I'd like you to attach /tmp/syslog and /tmp/anaconda.log to this bug report if
> you can.    

BTW: which busybox?  I get dropped into bash with almost no utilities installed.  I had to copy cp and ls etc on the USB stick.  Anyway, I'll attach the two files.

Comment 20 Ulrich Drepper 2010-04-26 20:27:53 UTC
Created attachment 409283 [details]
syslog after failed wlan lookup

The e1000e modules hasn't been removed and re-added.

Comment 21 Ulrich Drepper 2010-04-26 20:28:24 UTC
Created attachment 409284 [details]
anaconda.log files

same situation as for syslog file.

Comment 22 Chris Lumens 2010-04-26 20:45:44 UTC
05:17:02,523 INFO kernel:e1000e: Intel(R) PRO/1000 Network Driver - 1.0.2-k2
05:17:02,523 INFO kernel:e1000e: Copyright (c) 1999 - 2009 Intel Corporation.
05:17:02,523 INFO kernel:e1000e 0000:00:19.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
05:17:02,524 DEBUG kernel:e1000e 0000:00:19.0: setting latency timer to 64
05:17:02,524 DEBUG kernel:  alloc irq_desc for 28 on node -1
05:17:02,524 DEBUG kernel:  alloc kstat_irqs on node -1
05:17:02,524 DEBUG kernel:e1000e 0000:00:19.0: irq 28 for MSI/MSI-X
05:17:02,525 INFO kernel:e1000e 0000:00:19.0: PCI INT A disabled
05:17:02,525 WARN kernel:e1000e: probe of 0000:00:19.0 failed with error -2

Comment 23 Liam Li 2010-05-04 09:24:38 UTC
I have the same issue during install on DELL optiplex760,my hardware is:

http://www.smolts.org/client/show/pub_412e77b3-4657-47bd-a176-426aea56a8aa

Comment 24 Ulrich Drepper 2010-05-26 19:17:19 UTC
Nothing fixed in F13 GA.

The e1000e driver still doesn't work after startup, only after removing and re-inserting it.

The kernel mode driver for the Intel chip still doesn't do the right thing, the screen is blank.  I thought ajax mentioned the support would be backported.

I.e., no progress whatsoever since F13-alpha.

Comment 25 Matt Wringe 2010-06-22 01:17:10 UTC
Created attachment 425792 [details]
hacked up patch which makes the display work on Thinkpad x201

The video display problem isn't something with the fedora kernel, it doesn't work in the upstream kernel either (nor the f14 kernels). It does work with the RHEL 6 Beta kernel, is anyone trying to push the rhel kernel patches upstream?

I have attached a very hacked up patch that makes my x201 work with the laptop screen. Hopefully someone who knows this stuff better can determine what the actual patch should be and get this properly fixed.

Now if only the display port on the dock would work properly :(

Comment 26 Ulrich Drepper 2010-06-23 00:27:56 UTC
(In reply to comment #25)
> Created an attachment (id=425792) [details]
> hacked up patch which makes the display work on Thinkpad x201

Indeed, I can confirm that.  Checked with 2.6.33.5-133.  Thanks a lot.

Comment 27 Taavi Tuisk 2010-07-06 10:31:05 UTC
I can confirm the problems with arrandale graphics on Thinkpad x201. More context can be found at https://bugs.launchpad.net/fedora/+source/linux/+bug/554569

Comment 28 Chuck Ebbert 2010-07-13 19:40:48 UTC
Is the 2.6.34.1-11.fc13 kernel from koji any better?

Comment 29 Ulrich Drepper 2010-07-13 19:58:54 UTC
(In reply to comment #28)
> Is the 2.6.34.1-11.fc13 kernel from koji any better?    

No, the screen is still turned off.

Comment 30 Christopher Aillon 2010-07-13 20:27:43 UTC
http://lists.freedesktop.org/archives/intel-gfx/2010-July/007328.html is the patch that is likely needed...

Comment 32 Ulrich Drepper 2010-07-14 03:40:05 UTC
(In reply to comment #30)
> http://lists.freedesktop.org/archives/intel-gfx/2010-July/007328.html is the
> patch that is likely needed...    

Indeed, Adam's patch works.  I might try tomorrow connecting an external monitor.  With the patch from comment #25 this doesn't work.  The screen turns off when trying to mirror the screen.

Comment 33 Chuck Ebbert 2010-07-14 08:56:50 UTC
I don't see this patch in the drm-next git tree.

Comment 34 Ulrich Drepper 2010-07-15 14:00:38 UTC
When using an external projector on a machine using Adam's patch it works in principle.  Except when I try to mirror the screens.  The laptop has a resolution of 1280x800, the mini projector I use has 640x480.  Upon connecting the projector I see the extended desktop and can move windows there.  But once I select to mirror the screen the laptop screen turns off and the signal to the projector is also turned off.

Is this also a frequency selection issue?  It's certainly not in the same category as this bug (at least the machine boots) but might be related.  I'll open a new bug if I get told to do so.

Comment 35 Chuck Ebbert 2010-07-18 15:06:33 UTC
Patch went in 2.6.34.1-18.fc13

Open another bug for the external display issue and reference this bug in case they're related.

Comment 36 Sergio Monteiro Basto 2010-07-19 22:31:31 UTC
bug: [Ironlake LVDS] Dell E6410 boots to black screen , https://bugs.freedesktop.org/show_bug.cgi?id=28746 and bug :[Arrandale] No output (black) on eDP https://bugs.freedesktop.org/show_bug.cgi?id=28070 seems to be a similar bug , 
which has been closed after this patch: 
http://lists.freedesktop.org/archives/intel-gfx/2010-June/007232.html
which was applied on 2.6.33.5-137.fc13.x86_64 

HTH

Comment 37 Ulrich Drepper 2010-07-20 04:54:43 UTC
(In reply to comment #35)
> Patch went in 2.6.34.1-18.fc13

Confirmed.  Work with 2.6.34.1-20.fc13.x86_64.

There was one other issue which prevented installation (the e1000e driver doesn't work, has to be re-inserted).  I haven't tested this recently.

As far as I am concerned the bug can be closed.


> Open another bug for the external display issue and reference this bug in case
> they're related.    

Will do.

Comment 38 John Walicki 2010-07-21 04:10:17 UTC
The IBM team confirmed on multiple ThinkPad x201 systems that the new 2.6.34.1-20.fc13 kernel does indeed resolve the video problem.  Excellent - many thanks to everyone for their help.

I agree that the bug can be closed.

Comment 39 Fedora Update System 2010-07-24 14:11:13 UTC
kernel-2.6.33.6-147.2.4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.33.6-147.2.4.fc13

Comment 40 Fedora Update System 2010-07-27 02:47:45 UTC
kernel-2.6.33.6-147.2.4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.33.6-147.2.4.fc13

Comment 41 Fedora Update System 2010-08-03 01:11:02 UTC
kernel-2.6.33.6-147.2.4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.