Bug 572806 - [abrt] crash in gtorrentviewer-0.2b-18.fc12: Process /usr/bin/gtorrentviewer was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in gtorrentviewer-0.2b-18.fc12: Process /usr/bin/gtorrentviewer ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtorrentviewer
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:27e6b9864130eb8fc5772027914...
: 593734 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-12 03:51 UTC by Mustafa Mehmed
Modified: 2010-07-21 08:11 UTC (History)
3 users (show)

Fixed In Version: gtorrentviewer-0.2b-20.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-21 08:11:15 UTC


Attachments (Terms of Use)
File: backtrace (21.36 KB, text/plain)
2010-03-12 03:51 UTC, Mustafa Mehmed
no flags Details

Description Mustafa Mehmed 2010-03-12 03:51:53 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gtorrentviewer /storage/data/torrents-new/9EDB68309A0FA22B9079704F72AFB4E4FA67FC3F.torrent
comment: Clicked on a torrent file to view (default behaviour in my gnome setup)
component: gtorrentviewer
executable: /usr/bin/gtorrentviewer
kernel: 2.6.32.9-70.fc12.x86_64
package: gtorrentviewer-0.2b-18.fc12
rating: 4
reason: Process /usr/bin/gtorrentviewer was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Mustafa Mehmed 2010-03-12 03:51:55 UTC
Created attachment 399547 [details]
File: backtrace

Comment 2 "FeRD" (Frank Dana) 2010-04-03 16:01:14 UTC

How to reproduce
-----
1. Open torrent file
2. Switch to "Trackers Details" tab
3. Click Refresh button, and *boom*


Comment
-----
Torrent file was for a single, private tracker. It loaded in Azureus, and same torrent was successfully joined and files downloaded.

Comment 3 Karel Klíč 2010-05-25 08:48:13 UTC
*** Bug 593734 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2010-06-25 14:59:55 UTC
gtorrentviewer-0.2b-20.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gtorrentviewer-0.2b-20.fc13

Comment 5 Fedora Update System 2010-06-25 15:00:05 UTC
gtorrentviewer-0.2b-20.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gtorrentviewer-0.2b-20.fc12

Comment 6 Paul Howarth 2010-06-25 15:01:59 UTC
Thanks for the details on how to reproduce the problem; it was invaluable in working out the fix.

Comment 7 Fedora Update System 2010-06-28 17:21:41 UTC
gtorrentviewer-0.2b-20.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtorrentviewer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gtorrentviewer-0.2b-20.fc13

Comment 8 Fedora Update System 2010-06-28 17:22:12 UTC
gtorrentviewer-0.2b-20.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtorrentviewer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gtorrentviewer-0.2b-20.fc12


Note You need to log in before you can comment on or make changes to this bug.