Bug 57285 - oaf-0.6.7 make fails to compile
oaf-0.6.7 make fails to compile
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: oaf (Show other bugs)
7.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-08 14:14 EST by Mark Pawson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-08 14:14:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Pawson 2001-12-08 14:14:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
My system is an AMD Althon 800MHz, with 128MB of RAM.
I use Red Hat 7.0
GCC 2.95.3
GNU make 3.79
and binutils 2.11.2 (the latest version)
GTK+1.2.10 and glib 1.2.10
Kernel 2.4.9

I downloaded oaf-0.6.7.  I successfully configured it with 
just ./configure.  Then ran I ran make and it failed with an error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run ./configure
2.run make
3.observe error
	

Actual Results:  The output from ./configure is listed below:

creating cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking whether to enable maintainer-specific portions of Makefiles... no
checking for Cygwin environment... no
checking for mingw32 environment... no
checking how to run the C preprocessor... /lib/cpp
checking host system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for ld used by GCC... /usr/local/i686-pc-linux-gnu/bin/ld
checking if the linker (/usr/local/i686-pc-linux-gnu/bin/ld) is GNU ld... 
yes
checking for /usr/local/i686-pc-linux-gnu/bin/ld option to reload object 
files... -r
checking for BSD-compatible nm... /usr/local/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependant libraries... pass_all
checking for object suffix... o
checking for executable suffix... no
checking command to parse /usr/local/bin/nm -B output... ok
checking for dlfcn.h... no
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... 
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/local/i686-pc-linux-gnu/bin/ld) supports 
shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
creating libtool
checking for perl... /usr/bin/perl
checking whether build environment is sane... yes
checking for gcc... (cached) gcc
checking whether the C compiler (gcc -g -O2 ) works... yes
checking whether the C compiler (gcc -g -O2 ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for flex... flex
checking for flex... (cached) flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for bison... bison -y
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln -s works... (cached) yes
checking whether make sets ${MAKE}... (cached) yes
checking for strerror in -lcposix... no
checking for ranlib... (cached) ranlib
checking for ANSI C header files... no
checking for working const... yes
checking for inline... inline
checking for off_t... no
checking for size_t... no
checking for working alloca.h... yes
checking for alloca... yes
checking for unistd.h... no
checking for getpagesize... yes
checking for working mmap... yes
checking for argz.h... no
checking for limits.h... no
checking for locale.h... no
checking for nl_types.h... no
checking for malloc.h... no
checking for string.h... no
checking for unistd.h... (cached) no
checking for sys/param.h... no
checking for getcwd... yes
checking for munmap... yes
checking for putenv... yes
checking for setenv... yes
checking for setlocale... yes
checking for strchr... yes
checking for strcasecmp... yes
checking for strdup... yes
checking for __argz_count... yes
checking for __argz_stringify... yes
checking for __argz_next... yes
checking for stpcpy... yes
checking whether NLS is requested... yes
checking for libintl.h... no
checking whether catgets can be used... no
found xgettext program is not GNU xgettext; ignore it
sed: can't read ./intl/po2tbl.sed.in: No such file or directory
checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.0... yes
checking for orbit-config... /usr/bin/orbit-config
checking for ORBit - version >= 0.5.1... yes
checking for orbit-idl... /usr/bin/orbit-idl
checking for xml-config... xml-config
checking for gtkdoc-mkdb... false
checking for poptDupArgv in -lpopt... yes
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for ANSI C header files... (cached) no
checking for fcntl.h... no
checking for unistd.h... (cached) no
checking for alloca.h... (cached) yes
checking for malloc.h... (cached) no
checking for working const... (cached) yes
checking for select... yes
checking for strcspn... yes
checking for strdup... (cached) yes
checking for strtol... yes
checking for snprintf... yes
checking for usleep... yes
checking for nanosleep... yes
checking for unsetenv... yes
checking for perl... /usr/bin/perl
checking for ps... /bin/ps
checking for POSIX ps... yes
updating cache ./config.cache
creating ./config.status
creating Makefile
creating oaf.spec
creating idl/Makefile
creating docs/Makefile
creating api-docs/Makefile
creating liboaf/Makefile
creating liboaf/liboaf-version.h
creating oafd/Makefile
creating test/Makefile
creating test/oaf-slay
creating utils/Makefile
creating intl/Makefile
creating po/Makefile.in
creating oaf-config
creating oafConf.sh
creating config.h

Here is the output from make:

make  all-recursive
make[1]: Entering directory `/home/Test/Gnome/oaf-0.6.7'
Making all in po
make[2]: Entering directory `/home/Test/Gnome/oaf-0.6.7/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/Test/Gnome/oaf-0.6.7/po'
Making all in intl
make[2]: Entering directory `/home/Test/Gnome/oaf-0.6.7/intl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/Test/Gnome/oaf-0.6.7/intl'
Making all in docs
make[2]: Entering directory `/home/Test/Gnome/oaf-0.6.7/docs'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/Test/Gnome/oaf-0.6.7/docs'
Making all in idl
make[2]: Entering directory `/home/Test/Gnome/oaf-0.6.7/idl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/Test/Gnome/oaf-0.6.7/idl'
Making all in liboaf
make[2]: Entering directory `/home/Test/Gnome/oaf-0.6.7/liboaf'
/usr/bin/orbit-idl -I../idl --define=OAF_COMPILATION ../idl/oaf.idl
Error: Empty file

** WARNING **: ../idl/oaf.idl compilation failed
touch stamp-idl
/usr/bin/orbit-idl -I../idl --define=GNOME_FACTORY_COMPILATION ../idl/oaf-
factory.idl
Error: Empty file

** WARNING **: ../idl/oaf-factory.idl compilation failed
touch stamp-factory-idl
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..	
				-I..				-I../liboaf
				-I../liboaf			-
DOAF_LOCALEDIR=\""/usr/local/share/locale"\"		-
I/usr/local/include/glib-1.2 -I/usr/local/lib/glib/include -
I/usr/include/orbit-1.0					-
I/usr/local/include/glib-1.2 -I/usr/local/lib/glib/include		
			-DVERSION=\"0.6.7\"			    -g -
O2 -c oaf-stubs.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I.. -I../liboaf -I../liboaf -
DOAF_LOCALEDIR=\"/usr/local/share/locale\" -I/usr/local/include/glib-1.2 -
I/usr/local/lib/glib/include -I/usr/include/orbit-1.0 -
I/usr/local/include/glib-1.2 -I/usr/local/lib/glib/include -
DVERSION=\"0.6.7\" -g -O2 -c oaf-stubs.c  -fPIC -DPIC -o oaf-stubs.lo
gcc: oaf-stubs.c: No such file or directory
gcc: No input files
make[2]: *** [oaf-stubs.lo] Error 1
make[2]: Leaving directory `/home/Test/Gnome/oaf-0.6.7/liboaf'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Test/Gnome/oaf-0.6.7'
make: *** [all-recursive-am] Error 2



Expected Results:  The compilation should have been sucessful

Additional info:

N/A
Comment 1 Owen Taylor 2002-01-24 10:46:10 EST
Doesn't seem Red Hat related, looks like a corrupted tarball or something.

ftp://people.redhat.com/hp/gnomehide has 7.2 RPMS of oaf-0.6.7.

Note You need to log in before you can comment on or make changes to this bug.