Bug 572876 - Not nss update
Not nss update
Status: CLOSED DUPLICATE of bug 572832
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
12
i686 Linux
low Severity high
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-12 04:07 EST by Sigitas Mockus
Modified: 2010-03-12 17:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-12 13:08:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Update fail. (257.86 KB, image/jpeg)
2010-03-12 04:12 EST, Sigitas Mockus
no flags Details

  None (edit)
Description Sigitas Mockus 2010-03-12 04:07:06 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/532.9 (KHTML, like Gecko) Chrome/5.0.307.11 Safari/532.9

[root@localhost Sigitas]# yum update
Loaded plugins: fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: ftp.funet.fi
 * livna: wftp.tu-chemnitz.de
 * rpmfusion-free: fedora.tu-chemnitz.de
 * rpmfusion-free-updates: fedora.tu-chemnitz.de
 * rpmfusion-nonfree: fedora.tu-chemnitz.de
 * rpmfusion-nonfree-updates: fedora.tu-chemnitz.de
 * updates: ftp.funet.fi
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package nss.i686 0:3.12.6-1.2.fc12 set to be updated
--> Processing Dependency: nss-util = 3.12.6 for package: nss-3.12.6-1.2.fc12.i686
---> Package nss-sysinit.i686 0:3.12.6-1.2.fc12 set to be updated
---> Package nss-tools.i686 0:3.12.6-1.2.fc12 set to be updated
--> Finished Dependency Resolution
nss-3.12.6-1.2.fc12.i686 from updates has depsolving problems
  --> Missing Dependency: nss-util = 3.12.6 is needed by package nss-3.12.6-1.2.fc12.i686 (updates)
Error: Missing Dependency: nss-util = 3.12.6 is needed by package nss-3.12.6-1.2.fc12.i686 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Reproducible: Always
Comment 1 Sigitas Mockus 2010-03-12 04:12:08 EST
Created attachment 399592 [details]
Update fail.

Not update those packages.
Comment 2 Sigitas Mockus 2010-03-12 07:12:58 EST
Fix problem this su
yum update nss-util --enablerepo=u*g then su yum update and works ok.
Comment 3 Elio Maldonado Batiz 2010-03-12 11:13:00 EST
I submitted the packages to updates testing in the following order: 
i   - nsspr 4.8.4
ii  - nss-util 3.12.6
iii - nss-softokn 3.12.4-15  (probably earlier that the others)
iv  - nss 3.12.6

Once they got sufficient Karma they were pushed to stable, probably nss got pushed ahead of the others. Perhaps I should have waited longer between submissions. A day perhaps?

Judging from the latest Bodhi/Koji notifications, they should all be in by now. Please try again.
Comment 4 Elio Maldonado Batiz 2010-03-12 12:01:18 EST
I checked and not all packages were on stable. I pushed nspr 4.8.4 to stable on c12 and f11. Also pushed nss-softokn 3.12.4-15 for some other fedora versions.
Comment 5 Michael Cronenworth 2010-03-12 13:08:29 EST
Elio, would it be beneficial to group nss and nspr into one bodhi push in the future?

*** This bug has been marked as a duplicate of bug 572832 ***
Comment 6 Elio Maldonado Batiz 2010-03-12 13:20:59 EST
(In reply to comment #5) Yes, I probably should do it this way. I would also include the nss-util and nss-softokn packages that nss depends on. 

This seems to be the same as the following suggestion Bill gave me:

Did you know that bodhi lets you add multiple packages to an update?
(You may need to use the web UI to do this.) If you add these
all as a single update, it ensures that they will remain in
sync.

For an example of a multi-package update, see:
https://admin.fedoraproject.org/updates/galeon-2.0.7-20.fc12,gnome-python2-extras-2.25.3-16.fc12,perl-Gtk2-MozEmbed-0.08-6.fc12.11,blam-1.8.5-22.fc12,gnome-web-photo-0.9-5.fc12,mozvoikko-1.0-8.fc12,firefox-3.5.8-1.fc12,xulrunner-1.9.1.8-1.fc12

Note You need to log in before you can comment on or make changes to this bug.