Bug 572958 - Can't create snapshots!
Can't create snapshots!
Status: CLOSED DUPLICATE of bug 503726
Product: Fedora
Classification: Fedora
Component: btrfs-progs (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-12 08:23 EST by Mario Ceresa
Modified: 2010-03-12 08:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-12 08:27:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Ceresa 2010-03-12 08:23:26 EST
Description of problem:
I'm unable to create a snapshot

Version-Release number of selected component (if applicable):
btrfs-progs-0.19.9.fc12
kernel-2.6.32.9-70.fc12

How reproducible:
Always

Steps to Reproduce:
1. Create a 300MB btrfs file, format and mount as a loop device:

dd if=/dev/zero of=btrfs.img count=300 bs=1M
losetup /dev/loop0 btrfs.img
mkfs.btrfs -L test /dev/loop0
mount /dev/loop0 /mnt/btrfs/

2. Create a snapshot:
btrfsctl -s snap0 /mnt/btrfs/
  
Actual results:
ioctl:: Inappropriate ioctl for device

Expected results:
Create snapshot

Additional info:
# modinfo btrfs
filename:       /lib/modules/2.6.32.9-70.fc12.i686/kernel/fs/btrfs/btrfs.ko
license:        GPL
srcversion:     515D00B63448802E7928F98
depends:        libcrc32c,zlib_deflate
vermagic:       2.6.32.9-70.fc12.i686 SMP mod_unload 686

As reported in 
http://www.linuxquestions.org/questions/linux-software-2/btrfs-filesystem-problems-with-btrfsctl-when-shrinking-and-defragmenting-fs-723177/

the problem might be a version mismatch between the kernel module and the utility package. But I don't know how to check the kernel module version!
Comment 1 Mario Ceresa 2010-03-12 08:27:41 EST
I just noticed that there was a duplicate bug. I didn't find it neither looking with google nor with the bodhi "bug reports" function.

I'll close the bug, sorry for the noise.

Mario

*** This bug has been marked as a duplicate of bug 503726 ***

Note You need to log in before you can comment on or make changes to this bug.