Bug 57308 - ghostscript-6.51-16 crash viewing font page
ghostscript-6.51-16 crash viewing font page
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: ghostscript (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-09 22:25 EST by Jonathan Kamens
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 11:09:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-12-09 22:25:53 EST
I downloaded FontSheets.ps from
http://www.glyphic.com/free/fontsheets/fontsheets.html and attempted to
view it with "gs FontSheets.ps" with ghostscript-6.51-16.  It dies when I
attempt to move from the first to the second page by hitting return. 
Here's what it says when it dies:

Error: /rangecheck in --stringwidth--
Operand stack:
   (FutoGoB101:Kanji)   --nostringval--   false   (VFlib Vector Font
Library)   FutoGoB101-Bold-Ext-H   ()   --dict:12/12(ro)(G)--   177.75  
(abcDEFGHIJKLMNOPQRSTUVWXYZ)   (&123)   141.75  
(abcDEFGHIJKLMNOPQRSTUVWXY)   141.75
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1  
3   %oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   %array_continue   --nostringval--  
--nostringval--   %loop_continue   --nostringval--   --nostringval--  
--nostringval--   %array_continue   --nostringval--   --nostringval--  
--nostringval--   --nostringval--   %loop_continue   --nostringval--  
--nostringval--   --nostringval--
Dictionary stack:
   --dict:1026/1476(ro)(G)--   --dict:0/20(G)--   --dict:90/200(L)--  
--dict:125/200(L)--
Current allocation mode is local
Current file position is 16974
GNU Ghostscript 6.51: Unrecoverable error, exit code 1

I note the comment in the changelog entry for 6.51-2: "I know that there
are going to be problems in the japanese code, and I need to turn on the
cjk font map from adobe, but it /works/ at the moment."  I wonder if
perhaps this is one fo the referenced problems in the japanese code?

I made this problem go away by commenting out all the uncommented lines in
vflib/kconfig.ps.  But then I got errors about GothicBBB.  I made those go
away by removing all of the files in
/usr/share/ghostscript/Resource/CIDFont.  Then I was able to use
FontSheets.ps, until I attempted to add "loadallfonts" right after
"%%BeginProlog", at which point I got this error, which I don't know what
to do about.  Note the third argument on the stack, which seems to have
some sort of data corruption in it.

Error: /typecheck in --cvs--
Operand stack:
   (*)   --nostringval--  
(NimbusSanL-BoldItalx-Italiceuelice\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000)  
--dict:0/20(L)--   --dict:0/20(L)--   --dict:127/177(L)--  
Hershey-Gothic-Italian-Bold   --nostringval--   Hershey-Greek-Simplex  
--nostringval--   Hershey-Gothic-German-Oblique   --nostringval--  
Hershey-Greek-Complex   --nostringval--   Hershey-Gothic-German-Bold  
--nostringval--   Hershey-Script-Simplex-Oblique   --nostringval--  
Hershey-Symbol   --nostringval--   Hershey-Gothic-English-SemiBold  
--nostringval--   Hershey-Script-Simplex-Bold   --nostringval--  
Hershey-Plain-Simplex-Oblique   --nostringval--  
Hershey-Gothic-English-Oblique   --nostringval--  
Hershey-Script-Complex-Oblique   --nostringval--  
Hershey-Plain-Simplex-Bold-Oblique   --nostringval--  
Hershey-Gothic-English-Bold   --nostringval--  
Hershey-Script-Complex-Bold   --nostringval--  
Hershey-Plain-Simplex-Bold   --nostringval--  
Hershey-Plain-Triplex-Bold-Italic   --nostringval--  
Hershey-Plain-Oblique   --nostringval--   Hershey-Plain-Triplex-Bold  
--nostringval--   Hershey-Plain-Bold-Oblique   --nostringval--  
Hershey-Plain-Duplex-Bold-Italic   --nostringval--   Hershey-Plain-Bold  
--nostringval--   Hershey-Plain-Duplex-Bold   --nostringval--  
Hershey-Plain-Simplex   --nostringval--   Hershey-Gothic-Italian-Oblique  
--nostringval--   Hershey-Plain   --nostringval--   --nostringval--  
(90ms-RKSJ-UCS2)   Hershey-Gothic-Italian-Oblique
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1  
3   %oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
4   4   %oparray_pop   --nostringval--   6   --nostringval--   false   1  
%stopped_push   --nostringval--   62   5   %oparray_pop   --nostringval--  
64   --nostringval--   false   1   %stopped_push   --nostringval--  
--nostringval--   --dict:16/24(ro)(G)--  
(/usr/share/ghostscript/Resource/CMap/*)  
(/usr/share/ghostscript/Resource/CMap/90ms-RKSJ-UCS2\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000\000)  
(file_enum)   --nostringval--   %file_continue   --nostringval--  
--nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1026/1476(ro)(G)--   --dict:0/20(G)--   --dict:90/200(L)--  
--dict:125/200(L)--   --dict:17/17(ro)(G)--
Current allocation mode is local
Last OS error: 2
Current file position is 16712
GNU Ghostscript 6.51: Unrecoverable error, exit code 1
Comment 1 Tim Waugh 2002-01-10 12:17:22 EST
Seems to be kanji-related.
Comment 2 Tim Waugh 2002-02-22 07:58:07 EST
Still happens in 6.53.
Comment 3 Tim Waugh 2002-05-22 07:00:06 EDT
Happens in 7.05-3 too (from rawhide).
Comment 4 Alex Cherepanov 2002-10-14 10:27:24 EDT
The sample file is incorrect. The file is not aware of Asian fonts and
CIDFont-CMap interaction. The error happens when the file attempts
to interpret a string of 25 characters (odd number) in double-byte
encoding.
Comment 5 Tim Waugh 2002-10-14 16:18:29 EDT
So, NOTABUG?
Comment 6 Alex Cherepanov 2002-10-15 11:09:46 EDT
Yes, Ghostscript correctly detects the error in PS program.

Note You need to log in before you can comment on or make changes to this bug.