Bug 573100 - update wqy-bitmap-fonts to the new upstream release 1.0.0-RC1
Summary: update wqy-bitmap-fonts to the new upstream release 1.0.0-RC1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wqy-bitmap-fonts
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Qianqian Fang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-12 20:36 UTC by Qianqian Fang
Modified: 2010-03-16 00:54 UTC (History)
5 users (show)

Fixed In Version: wqy-bitmap-fonts-1.0.0-0.1.rc1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-14 13:36:30 UTC
Type: ---


Attachments (Terms of Use)

Description Qianqian Fang 2010-03-12 20:36:46 UTC
New upstream release (version 1.0.0-RC1) is available at 
http://sourceforge.net/projects/wqy/files/wqy-bitmapfont/1.0.0-RC1/

need to update to the new version.

Comment 1 Fedora Update System 2010-03-12 20:37:29 UTC
wqy-bitmap-fonts-1.0.rc1-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wqy-bitmap-fonts-1.0.rc1-0.fc12

Comment 2 Fedora Update System 2010-03-12 20:37:34 UTC
wqy-bitmap-fonts-1.0.rc1-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wqy-bitmap-fonts-1.0.rc1-0.fc11

Comment 3 Fedora Update System 2010-03-12 20:37:38 UTC
wqy-bitmap-fonts-1.0.rc1-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/wqy-bitmap-fonts-1.0.rc1-0.fc13

Comment 4 Mamoru TASAKA 2010-03-14 04:43:16 UTC
EVR (Epoch-Version-Release) must be "1.0-0.X.rc1" (where X is
some integer), otherwise when 1.0 is released, upgrade path
cannot correctly be kept because rpm thinks "1.0rc1 > 1.0".

Also it seems that the correct version seems "1.0.0", not "1.0"

Comment 5 Fedora Update System 2010-03-14 05:21:45 UTC
wqy-bitmap-fonts-1.0.0-0.1.rc1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wqy-bitmap-fonts-1.0.0-0.1.rc1.fc12

Comment 6 Fedora Update System 2010-03-14 05:21:51 UTC
wqy-bitmap-fonts-1.0.0-0.1.rc1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wqy-bitmap-fonts-1.0.0-0.1.rc1.fc11

Comment 7 Fedora Update System 2010-03-14 05:21:59 UTC
wqy-bitmap-fonts-1.0.0-0.1.rc1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/wqy-bitmap-fonts-1.0.0-0.1.rc1.fc13

Comment 8 Qianqian Fang 2010-03-14 05:24:40 UTC
(In reply to comment #4)
> EVR (Epoch-Version-Release) must be "1.0-0.X.rc1" (where X is
> some integer), otherwise when 1.0 is released, upgrade path
> cannot correctly be kept because rpm thinks "1.0rc1 > 1.0".
> 
> Also it seems that the correct version seems "1.0.0", not "1.0"    

Thanks for pointing this out. The issue is now corrected. The new EVR looks
like 1.0.0-0.1.rc1. Updates for F11~F13 were submitted.

Comment 9 Mamoru TASAKA 2010-03-14 05:51:46 UTC
Thank you for quick update. New pkgs seems correctly versioned.

Now would you
- untag wqy-bitmap-fonts-1.0.rc1-0.fc14 on koji
  (i.e. $ koji untag-pkg dist-f14 wqy-bitmap-fonts-1.0.rc1-0.fc14 )
- Revoke bodhi submittion for 1.0.rc1-0.fcYYYY

to make it sure that anything unexpected won't happen during push
process?

Comment 10 Qianqian Fang 2010-03-14 06:07:28 UTC
(In reply to comment #9)
> Thank you for quick update. New pkgs seems correctly versioned.
> 
> Now would you
> - untag wqy-bitmap-fonts-1.0.rc1-0.fc14 on koji
>   (i.e. $ koji untag-pkg dist-f14 wqy-bitmap-fonts-1.0.rc1-0.fc14 )

done

> - Revoke bodhi submittion for 1.0.rc1-0.fcYYYY

done

> 
> to make it sure that anything unexpected won't happen during push
> process?    

let me know if there is anything else for getting the update through.

thanks

Comment 11 Qianqian Fang 2010-03-14 06:08:41 UTC
by the way, shall I untag F11~F13 too?

Comment 12 Mamoru TASAKA 2010-03-14 06:17:27 UTC
(In reply to comment #11)
> by the way, shall I untag F11~F13 too?    

Not strictly needed. F-14 is special because all pkgs rebuilt
for F-14 (devel) will be automatically pushed into repository.

Comment 13 Fedora Update System 2010-03-14 13:36:26 UTC
wqy-bitmap-fonts-1.0.0-0.1.rc1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-03-16 00:35:26 UTC
wqy-bitmap-fonts-1.0.0-0.1.rc1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-03-16 00:54:15 UTC
wqy-bitmap-fonts-1.0.0-0.1.rc1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.