Bug 57320 - pam and NIS - HOME not found for rexec etc.
Summary: pam and NIS - HOME not found for rexec etc.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-10 12:15 UTC by Michael Redinger
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 08:11:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of rexec and local user (13.22 KB, text/plain)
2001-12-10 12:15 UTC, Michael Redinger
no flags Details
strace of rexec and NIS user (11.76 KB, text/plain)
2001-12-10 12:16 UTC, Michael Redinger
no flags Details

Description Michael Redinger 2001-12-10 12:15:01 UTC
There seems to be a problem with pam (I'd suppose) that makes rexec, rsh
and others not get the correct directory.
This only happens with NIS, it works fine with local user accounts.
This definitely worked in 7.0. I _think_ I used this without problems in
7.1 too, but honestly I don't really know.

Some examples to demonstrate this:

# local user - works fine
$ rexec -l username -p xxx nishost pwd
/home/username

# NIS user - oops :(
$ rexec -l username -p xxx nishost pwd
No remote directory.
rexec: Error in rexec system call,
rexec: (The following system error may itself be in error)
rexec: No such file or directory

I'll attach two strace files.



2nd example:

Using xon from the XFree86 package does get you into your HOME directory
but to /.
The same is true when using xrsh (you can eg.
http://www.uni-kiel.de/campus/unix/RPMS/freeware/sparc/xrsh-5.8-2.sparc.SunOS-5.7.rpm
- this works fine as the
contained xrsh file is a shell script).

Comment 1 Michael Redinger 2001-12-10 12:15:51 UTC
Created attachment 40251 [details]
strace of rexec and local user

Comment 2 Michael Redinger 2001-12-10 12:16:32 UTC
Created attachment 40252 [details]
strace of rexec and NIS user

Comment 3 Nalin Dahyabhai 2002-03-08 00:08:40 UTC
What output do you get when you run "getent passwd username" on nishost?

Comment 4 Michael Redinger 2002-03-08 08:33:52 UTC
Seems to be ok.
[user]:[encoded password]:[uid]:[gid]:[gecos]:[home]:[shell]



Comment 5 Michael Redinger 2002-10-28 11:43:03 UTC
The problem still exists in 8.0.

Comment 6 Michael Redinger 2002-10-28 12:30:41 UTC
Just found out that things work fine as soon as I set the home directory o=rx

Not a solution, but it might help idfentifying the bug ...



Comment 7 Michael Redinger 2002-10-29 10:07:07 UTC
Finally found the reason - should have thought of this earlier ...

The HOME directories are mounted using NFS and root is mapped to anonymous.
If I export with no_root_squash, things work fine.

So this is not really a NIS but an NFS Problem.

I think this is a bug anyway ... 
(Hm, why does root need to access the user's home directory?)


Comment 8 Tomas Mraz 2004-10-20 08:11:57 UTC
This surely isn't a bug in pam.



Note You need to log in before you can comment on or make changes to this bug.