Bug 57324 - .ecm files can't represent removed packages
Summary: .ecm files can't represent removed packages
Status: CLOSED WONTFIX
Alias: None
Product: eCos
Classification: Retired
Component: ConfigTool (Show other bugs)
(Show other bugs)
Version: CVS
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Julian Smart
QA Contact: Julian Smart
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-10 14:04 UTC by Jonathan Larmour
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 16:08:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Larmour 2001-12-10 14:04:13 UTC
A .ecm (minimal configuration) file cannot represent a configuration where
a package has been removed from the configuration first.

For example if you started with the default template and added
CYGPKG_POSIX, you would get a conflict because of having two signal
implementations present. This would be resolved by removing
CYGPKG_LIBC_SIGNALS from the config. A configuration like that cannot be
represented in a .ecm file.

Comment 1 Alex Schuilenburg 2003-06-20 16:08:01 UTC
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id=57324


Note You need to log in before you can comment on or make changes to this bug.