Bug 573264 - Review Request: qt-assistant-adp - Compatibility version of Qt Assistant
Summary: Review Request: qt-assistant-adp - Compatibility version of Qt Assistant
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-13 20:15 UTC by Kevin Kofler
Modified: 2010-10-21 13:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-21 17:22:01 UTC
rdieter: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Kevin Kofler 2010-03-13 20:15:19 UTC
Spec URL: http://repo.calcforge.org/f14/qt-assistant-adp.spec
SRPM URL: http://apt.kde-redhat.org/apt/kde-redhat/SRPMS.kde/unstable/qt-assistant-adp-4.6.2-1.src.rpm (152.7 MiB)
Description:
The old version of Qt Assistant, based on Assistant Document Profile (.adp)
files, and the associated QtAssistantClient library, for compatibility with
applications providing help in that format.

New applications should use the new version of Qt Assistant introduced in Qt
4.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.


This is built from the Qt 4.6.2 tarball (thus the huge SRPM), as Qt 4.7 no longer includes this deprecated library/class/tool.

Comment 1 Rex Dieter 2010-03-13 20:39:08 UTC
1.  avoiding Conflicts
Since this is targeted for qt-4.7.0 anyway, we can possibly skip the Conflicts, and do something like this instead:

BuildRequires: qt4-devel >= 4.7.0

Requires qt4%{?_isa} >= %{_qt4_version}


I won't consider this a review blocker, but let's do our best to resolve the issue prior to releasing any builds.

Naming: ok

scriplets: ok

licensing: ok

macros: ok

no .desktop file: documented justification for exception, ok.

Otherwise, fairly simple and clean.


APPROVED.

Comment 2 Kevin Kofler 2010-03-13 20:47:37 UTC
The Conflicts are all versioned so as not to conflict with the current version. I don't see where the problem is there. It's quite a common idiom to have that kind of versioned Conflicts and we're also using it in other places in KDE. AIUI, the spirit of the guidelines is to avoid Conflicts between the current versions of packages.

Comment 3 Rex Dieter 2010-03-13 21:21:41 UTC
True, still, having a qt4 runtime dependency is largely required anyway, and by adding it, removes the need for conflicts in the first place.

Comment 4 Kevin Kofler 2010-03-13 22:57:58 UTC
New Package CVS Request
=======================
Package Name: qt-assistant-adp
Short Description: Compatibility version of Qt Assistant
Owners: kkofler than rdieter ltinkl
Branches: 
InitialCC: tuxbrewr

At this time, we only need this in devel.

Comment 5 Tom "spot" Callaway 2010-03-15 22:04:39 UTC
CVS done (by process-cvs-requests.py).

Comment 6 Rex Dieter 2010-04-21 17:22:01 UTC
imported/built for rawhide awhile back.

Comment 7 Kevin Kofler 2010-10-19 19:38:20 UTC
Package Change Request
======================
Package Name: qt-assistant-adp
New Branches: F-13
Owners: kkofler than rdieter ltinkl thomasj
InitialCC: tuxbrewr

Comment 8 Kevin Kofler 2010-10-19 19:50:11 UTC
Package Change Request
======================
Package Name: qt-assistant-adp
New Branches: f13
Owners: kkofler than rdieter ltinkl thomasj
InitialCC: tuxbrewr

Fixed the branch name.

Comment 9 Kevin Fenzi 2010-10-21 13:27:00 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.