Bug 573273 - myproxy-devel package is broken
Summary: myproxy-devel package is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: myproxy
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-13 20:35 UTC by Lev Shamardin
Modified: 2010-04-07 22:16 UTC (History)
2 users (show)

Fixed In Version: myproxy-5.1-2.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-16 00:41:59 UTC
Type: ---


Attachments (Terms of Use)

Description Lev Shamardin 2010-03-13 20:35:03 UTC
Description of problem:
myproxy-devel package is broken.

Version-Release number of selected component (if applicable):
myproxy-5.0-1.fc12.i686
myproxy-devel-5.0-1.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1. echo '#include <myproxy.h>' > test.c
2. gcc -c `pkg-config myproxy --cflags` test.c
  
Actual results:
In file included from /usr/include/globus/myproxy_authorization.h:5,
                 from /usr/include/globus/myproxy.h:78,
                 from test.c:1:
/usr/include/globus/myproxy_server.h:54: error: expected ‘:’, ‘,’, ‘;’, ‘}’ or ‘__attribute__’ before ‘*’ token
In file included from test.c:1:
/usr/include/globus/myproxy.h:87:27: error: myproxy_usage.h: No such file or directory

Expected results:
This should work.

Additional info:
At least, some of the headers are definitely missing.

Comment 1 Lev Shamardin 2010-03-13 20:56:54 UTC
Appears to be a trivial upstream bug. Easily fixed by patching Makefile.am, package rebuilt with this patch seems to work fine.

--- myproxy.spec.orig	2010-03-13 23:55:41.000000000 +0300
+++ myproxy.spec	2010-03-13 23:56:13.000000000 +0300
@@ -18,6 +18,7 @@
 Source1:        myproxy.init
 Source2:        myproxy.sysconfig
 Source3:        README.Fedora
+Patch0:         myproxy-headers.patch
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
@@ -152,6 +153,7 @@
 
 %prep
 %setup -q
+%patch0 -p2
 cp -p %{SOURCE1} .
 cp -p %{SOURCE2} .
 cp -p %{SOURCE3} .
@@ -387,6 +389,7 @@
 %{_includedir}/globus/myproxy_sasl_client.h
 %{_includedir}/globus/myproxy_sasl_server.h
 %{_includedir}/globus/myproxy_server.h
+%{_includedir}/globus/myproxy_usage.h
 %{_includedir}/globus/verror.h
 %{_libdir}/libmyproxy.so
 %{_libdir}/pkgconfig/myproxy.pc

diff --git a/myproxy-5.1/Makefile.am b/myproxy-5.1/Makefile.am
index c2e5690..8481e03 100644
--- a/myproxy-5.1/Makefile.am
+++ b/myproxy-5.1/Makefile.am
@@ -91,6 +91,7 @@ include_HEADERS= \
 	myproxy_sasl_client.h \
 	myproxy_sasl_server.h \
 	myproxy_server.h \
+	myproxy_usage.h \
 	verror.h
 
 INCLUDES = $(GPT_INCLUDES)

Comment 2 Steve Traylen 2010-03-13 21:06:27 UTC
Was just getting there. Thanks.

upstream in CC as they have requested for bugs.

Will get new packages out in next day or two.

Thanks.

Steve

Comment 3 Fedora Update System 2010-03-14 10:12:29 UTC
myproxy-5.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/myproxy-5.1-1.fc12

Comment 4 Fedora Update System 2010-03-14 10:14:02 UTC
myproxy-5.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/myproxy-5.1-1.fc13

Comment 5 Steve Traylen 2010-03-14 10:15:45 UTC
Hi Lev,
 This is already fixed upstream in 5.1 which was is in testing repos
 since a few days.

 I've attached this bug to that release.

Steve

Comment 6 Fedora Update System 2010-03-14 11:35:15 UTC
myproxy-5.1-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/myproxy-5.1-1.el5

Comment 7 Fedora Update System 2010-03-16 00:41:54 UTC
myproxy-5.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-03-16 00:47:37 UTC
myproxy-5.1-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-03-16 00:53:39 UTC
myproxy-5.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-03-16 18:35:50 UTC
myproxy-5.1-2.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/myproxy-5.1-2.el4

Comment 11 Fedora Update System 2010-03-16 18:36:32 UTC
myproxy-5.1-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/myproxy-5.1-2.el5

Comment 12 Fedora Update System 2010-03-24 18:00:32 UTC
myproxy-5.1-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-04-07 22:16:21 UTC
myproxy-5.1-2.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.